diff mbox series

[bug#61659,v2,5/6] gnu: Add texlive-fvextra.

Message ID DM5PR03MB3163AB94C92ADF056FAF70F8C5A49@DM5PR03MB3163.namprd03.prod.outlook.com
State New
Headers show
Series [bug#61659,v2,1/6] gnu: Add texlive-catchfile. | expand

Commit Message

Morgan Smith Feb. 20, 2023, 9:05 p.m. UTC
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/tex.scm (texlive-fvextra): New variable.
---
 gnu/packages/tex.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index bf4a50973b..6aef6905a6 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11173,6 +11173,28 @@  (define-public texlive-floatflt
 tables and figures to be set left/right or alternating on even/odd pages.")
     (license license:lppl1.3+)))
 
+(define-public texlive-fvextra
+  (let ((template (simple-texlive-package
+                   "texlive-fvextra"
+                   (list "/doc/latex/fvextra/"
+                         "/source/latex/fvextra/"
+                         "/tex/latex/fvextra/")
+                   (base32
+                    "0nawx1fh55yhqspy5jgss2qmwpqmikfrg7628smk931rph9nq0aa"))))
+    (package
+      (inherit template)
+      (arguments
+       (substitute-keyword-arguments (package-arguments template)
+         ((#:tex-directory _ #t)
+          "latex/fvextra")))
+      (home-page "https://ctan.org/macros/latex/contrib/fvextra")
+      (synopsis "Extensions and patches for fancyvrb")
+      (description
+       "This package provides several extensions to fancyvrb, including
+automatic line breaking and improved math mode.  It also patches some fancyvrb
+internals.")
+      (license license:lppl1.3+))))
+
 (define-public bibtool
   (package
     (name "bibtool")