diff mbox series

[bug#61659,v2,1/6] gnu: Add texlive-catchfile.

Message ID DM5PR03MB3163122DB221CD130134496FC5A49@DM5PR03MB3163.namprd03.prod.outlook.com
State New
Headers show
Series [bug#61659,v2,1/6] gnu: Add texlive-catchfile. | expand

Commit Message

Morgan Smith Feb. 20, 2023, 9:04 p.m. UTC
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/tex.scm (texlive-catchfile): New variable.
---
 gnu/packages/tex.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index dafed9d3c3..efccba17cc 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5304,6 +5304,26 @@  (define-public texlive-carlisle
 in LaTeX documents; a jiffy to create slashed characters for physicists.")
     (license license:lppl)))
 
+(define-public texlive-catchfile
+  (let ((template (simple-texlive-package
+                   "texlive-catchfile"
+                   (list "/doc/latex/catchfile/"
+                         "/source/latex/catchfile/"
+                         "/tex/generic/catchfile/")
+                   (base32
+                    "1dpxy64hs0bjp8d2dmikflc995vazf7fi6z92w51fnj2fidgl8gx"))))
+    (package
+      (inherit template)
+      (arguments
+       (substitute-keyword-arguments (package-arguments template)
+         ((#:tex-directory _ #t)
+          "latex/catchfile")))
+      (home-page "https://ctan.org/macros/latex/contrib/catchfile")
+      (synopsis "Catch an external file into a macro")
+      (description
+       "Catchfile catches the contents of a file and puts it in a macro.")
+      (license license:lppl1.3+))))
+
 (define-public texlive-doi
   (package
     (inherit (simple-texlive-package