diff mbox series

[bug#38267] upgrade brlaser

Message ID CAO7Ox=ZUVhts=nm_giQvF=OXGmP5o9ey_BkMt_gxpaMgXBwg1A@mail.gmail.com
State Accepted
Headers show
Series [bug#38267] upgrade brlaser | expand

Commit Message

Nicolò Balzarotti Nov. 19, 2019, 10:06 a.m. UTC
Hi, yesterday I notified brlaser maintainer that a package is available on
guix and he asked us to upgrade (https://github.com/pdewacht/brlaser/pull/55),
so here's the patch.

I moved from using the commit # to the released version.
Since the let block was not needed anymore, the patch is unnecessary ugly,
let me know if I need to format it differently

Thanks, Nicolò

Comments

Marius Bakke Nov. 19, 2019, 9:05 p.m. UTC | #1
Nicolò Balzarotti <anothersms@gmail.com> writes:

> Hi, yesterday I notified brlaser maintainer that a package is available on
> guix and he asked us to upgrade (https://github.com/pdewacht/brlaser/pull/55),
> so here's the patch.

Nice, applied (with a conventional commit message), thank you!

I will happily accept a follow-up patch that removes all the printer
product names with something like "known to work with a wide array of
Brother printers, consult @url{foo,https://bar} for the full list".

WDYT?  :-)
diff mbox series

Patch

From fb8e66b1752a2ed411596f25b88cc26916b5a702 Mon Sep 17 00:00:00 2001
From: nixo <nicolo@nixo.xyz>
Date: Tue, 19 Nov 2019 10:44:15 +0100
Subject: [PATCH] gnu/packages/printers.scm: brlaser: Update to v6.

---
 gnu/packages/printers.scm | 84 +++++++++++++++++++++++----------------
 1 file changed, 49 insertions(+), 35 deletions(-)

diff --git a/gnu/packages/printers.scm b/gnu/packages/printers.scm
index 2d608bf3cb..7b2c2429dd 100644
--- a/gnu/packages/printers.scm
+++ b/gnu/packages/printers.scm
@@ -75,52 +75,66 @@  with Graphtec and Sihouette plotting cutters using an SVG file as its input.")
     (license license:gpl3+)))
 
 (define-public brlaser
-  (let ((commit "779f71e80fcc583f4537c844de141cf8e6a738fe")
-        (revision "1"))
-    (package
-      (name "brlaser")
-      (version (git-version "4" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://github.com/pdewacht/brlaser.git")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "0yrz9706660hdfi2y0ndp254r0vw9y665hwmxbbzfnz4ai13vj50"))))
-      (build-system cmake-build-system)
-      (arguments
-       `(#:configure-flags
-         (list (string-append "-DCUPS_DATA_DIR="
-                              (assoc-ref %outputs "out")
-                              "/share/cups")
-               (string-append "-DCUPS_SERVER_BIN="
-                              (assoc-ref %outputs "out")
-                              "/lib/cups"))))
-      (inputs
-       `(("ghostscript" ,ghostscript)
-         ("cups" ,cups)
-         ("zlib" ,zlib)))
-      (home-page "https://github.com/pdewacht/brlaser")
-      (synopsis "Brother laser printer driver")
-      (description "Brlaser is a CUPS driver for Brother laser printers.  This
+  (package
+    (name "brlaser")
+    (version "6")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/pdewacht/brlaser.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1995s69ksq1fz0vb34v0ndiqncrinbrlpmp70rkl6az7kag99s80"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:configure-flags
+       (list (string-append "-DCUPS_DATA_DIR="
+                            (assoc-ref %outputs "out")
+                            "/share/cups")
+             (string-append "-DCUPS_SERVER_BIN="
+                            (assoc-ref %outputs "out")
+                            "/lib/cups"))))
+    (inputs
+     `(("ghostscript" ,ghostscript)
+       ("cups" ,cups)
+       ("zlib" ,zlib)))
+    (home-page "https://github.com/pdewacht/brlaser")
+    (synopsis "Brother laser printer driver")
+    (description "Brlaser is a CUPS driver for Brother laser printers.  This
 driver is known to work with these printers:
 
 @enumerate
-@item Brother DCP-1510
+@item Brother DCP-1510 series
+@item Brother DCP-1600 series
 @item Brother DCP-7030
 @item Brother DCP-7040
 @item Brother DCP-7055
 @item Brother DCP-7055W
+@item Brother DCP-7060D
 @item Brother DCP-7065DN
 @item Brother DCP-7080
+@item Brother DCP-L2500D series
+@item Brother DCP-L2520D series
+@item Brother DCP-L2540DW series
+@item Brother HL-1110 series
 @item Brother HL-1200 series
+@item Brother HL-2030 series
+@item Brother HL-2140 series
+@item Brother HL-2220 series
+@item Brother HL-2270DW series
+@item Brother HL-5030 series
+@item Brother HL-L2300D series
 @item Brother HL-L2320D series
+@item Brother HL-L2340D series
 @item Brother HL-L2360D series
+@item Brother MFC-1910W
 @item Brother MFC-7240
 @item Brother MFC-7360N
-@end enumerate
-
-It partially works with printers from the Brother HL-L2300D series.")
-      (license license:gpl2+))))
+@item Brother MFC-7365DN
+@item Brother MFC-7840W
+@item Brother MFC-L2710DW series
+@item Lenovo M7605D
+@end enumerate")
+    (license license:gpl2+)))
-- 
2.24.0