diff mbox series

[bug#54630] utfcpp v3.2.1

Message ID CAFkJGRddNbOPc0UOtT6zJDVevHn4WZLwd6FLbDFRJASKmC5tYg@mail.gmail.com
State Accepted
Headers show
Series [bug#54630] utfcpp v3.2.1 | expand

Commit Message

Anadon March 29, 2022, 9:48 p.m. UTC

Comments

Tobias Geerinckx-Rice April 2, 2022, 10:44 p.m. UTC | #1
Anadon,

As begun in #guix: I've applied the patch (with a few modifications) and 
will build all dependents overnight.

I've changed utfcpp-2 to inherit from utfcpp and removed the indirection 
(via the unused utfcpp-3) of the latter.

Whilst Guix tolerates to the point of accepting pseudonyms in copyright 
statements, yours seems rather… redundant?  Is there a compelling reason 
not to use the name in your e-mail address?  Is it also a pseudonym?

Kind regards,

T G-R

Sent from a Web browser.  Excuse or enjoy my brevity.
diff mbox series

Patch

diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index cbc657172d..c2c1a66438 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -24,6 +24,7 @@ 
 ;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
 ;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
 ;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
+;;; Copyright © 2021 Anadon <joshua.r.marshall.1991@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -669,29 +670,18 @@  (define-public catdoc
 (define-public utfcpp
   (package
     (name "utfcpp")
-    (version "2.3.5")
+    (version "3.2.1")
     (source (origin
               (method git-fetch)
               (uri (git-reference
                      (url "https://github.com/nemtrif/utfcpp")
-                     (commit (string-append "v" version))))
+                     (commit (string-append "v" version))
+                     (recursive? #t)))
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1gr98d826z6wa58r1s5i7rz7q2x3r31v7zj0pjjlrc7gfxwklr4s"))))
+                "0gsbwif97i025bxgyax4fbf6v9z44zrca4s6wwd8x36ac8qzjppf"))))
     (build-system cmake-build-system)
-    (arguments
-     `(#:out-of-source? #f
-       #:phases
-       (modify-phases %standard-phases
-         (replace 'install              ; no install target
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (include (string-append out "/include"))
-                    (doc (string-append out "/share/doc/" ,name)))
-               (copy-recursively "source" include)
-               (install-file "README.md" doc)
-               #t))))))