[bug#34745,core-updates] gnu: libgc: Update to 7.6.12.

Message ID 20190304120435.2276-1-mbakke@fastmail.com
State Accepted
Headers show
Series [bug#34745,core-updates] gnu: libgc: Update to 7.6.12. | expand

Checks

Context Check Description
cbaines/comparison success View comparison
cbaines/applying patch fail Apply failed

Commit Message

Marius Bakke March 4, 2019, 12:04 p.m. UTC
* gnu/packages/bdw-gc.scm (libgc): Update to 7.6.12.
[arguments]: Add phase to avoid libatomic-ops propagation.
---
 gnu/packages/bdw-gc.scm | 18 +++++++++++++++---
 1 file changed, 15 insertions(+), 3 deletions(-)

Comments

Marius Bakke March 10, 2019, 5:55 p.m. UTC | #1
Marius Bakke <mbakke@fastmail.com> writes:

> * gnu/packages/bdw-gc.scm (libgc): Update to 7.6.12.
> [arguments]: Add phase to avoid libatomic-ops propagation.

Pushed in b0f5ec4ffb9fd509c84c0fcf125b2e038e543ebc.

Patch

diff --git a/gnu/packages/bdw-gc.scm b/gnu/packages/bdw-gc.scm
index 041e142ded..ba010ceee5 100644
--- a/gnu/packages/bdw-gc.scm
+++ b/gnu/packages/bdw-gc.scm
@@ -30,14 +30,14 @@ 
 (define-public libgc
   (package
    (name "libgc")
-   (version "7.6.8")
+   (version "7.6.12")
    (source (origin
             (method url-fetch)
             (uri (string-append "https://github.com/ivmai/bdwgc/releases"
                                 "/download/v" version "/gc-" version ".tar.gz"))
             (sha256
              (base32
-              "0n720a0i584ghcwmdsjiq6bl9ig0p9mrja29rp4cgsqvpz6wa2h4"))))
+              "10jhhi79d5brwlsyhwgpnrmc8nhlf7aan2lk9xhgihk5jc6srbvc"))))
    (build-system gnu-build-system)
    (arguments
     `(#:configure-flags
@@ -53,7 +53,19 @@ 
        ,@(if (hurd-triplet? (or (%current-system)
                                 (%current-target-system)))
              '("--disable-gcj-support")
-             '()))))
+             '()))
+      #:phases (modify-phases %standard-phases
+                 (add-after 'unpack 'adjust-pc-file
+                   (lambda* (#:key inputs #:allow-other-keys)
+                     (let ((libatomic-ops (assoc-ref inputs "libatomic-ops")))
+                       ;; GC 7.6.10 and later includes -latomic_ops in the
+                       ;; pkg-config file.  To avoid propagation, insert an
+                       ;; absolute reference so dependent programs can find it.
+                       (substitute* "bdw-gc.pc.in"
+                         (("@ATOMIC_OPS_LIBS@" match)
+                          (string-append "-L" libatomic-ops "/lib "
+                                         match)))
+                       #t))))))
    (native-inputs `(("pkg-config" ,pkg-config)))
    (inputs `(("libatomic-ops" ,libatomic-ops)))
    (outputs '("out" "debug"))