diff mbox series

[bug#57746] gnu: solvespace: Fix dependency

Message ID CAAGQtHzeonSC7Qi=2Z-UN=vszGTjSYagphsijtLo_YReoTWfcQ@mail.gmail.com
State Accepted
Headers show
Series [bug#57746] gnu: solvespace: Fix dependency | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Kristian Lein-Mathisen Sept. 12, 2022, 10:06 a.m. UTC
Hi,

A bug has come up in SolveSpace where doing File=>Open makes it crash. I've
traced it down to a missing  "FileChooser" in GTK.

I found a reference to FileChooser in other packages, like utox, in a
modify-phase. Copying that removes the problem for SolveSpace. I don't
fully understand what I'm doing here but I'm hoping this is still the right
solution.

Thank you,
K.

Comments

Christopher Baines Sept. 14, 2022, 8:43 a.m. UTC | #1
Kristian Lein-Mathisen <kristianlein@gmail.com> writes:

> Hi,
>
> A bug has come up in SolveSpace where doing File=>Open makes it
> crash. I've traced it down to a missing "FileChooser" in GTK.
>
> I found a reference to FileChooser in other packages, like utox, in a
> modify-phase. Copying that removes the problem for SolveSpace. I don't
> fully understand what I'm doing here but I'm hoping this is still the
> right solution.

This seems OK to me. I've tweaked the commit message to make it more
specific and pushed to master as
699ae7f5da5a2bfe5112fc7a1bdd4c25227bd4bd.

Thanks,

Chris
diff mbox series

Patch

From 8ffd67f3c5244c1a1cfb888ecaf520a3bbc7d079 Mon Sep 17 00:00:00 2001
From: Kristian Lein-Mathisen <kristianlein@gmail.com>
Date: Mon, 12 Sep 2022 11:51:02 +0200
Subject: [PATCH] gnu: solvespace: Fix dependency.

By opening File => Open in the menu, SolveSpace crashes with:

(solvespace:3891): GLib-GIO-ERROR **: 11:52:37.518: Settings schema 'org.gtk.Settings.FileChooser' is not installed
fish: Job 1, 'solvespace' terminated by signal SIGTRAP (Trace or breakpoint
trap)

This patch should fix that, showing the GTK FileChooser dialog instead.
Solution was taken from gnu/packages/messaging.scm (utox).

* gnu/packages/engineering.scm (solvespace): Fix dependency.
---
 gnu/packages/engineering.scm | 10 +++++++++-
 1 file changed, 9 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index a8b9f1e786..673ea8023b 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2952,7 +2952,15 @@  (define-public solvespace
                            (("message\\(STATUS \"Using in-tree mimalloc\"\\)")
                             "message(STATUS \"Using guix packaged mimalloc\")")
                            (("add_subdirectory\\(extlib/mimalloc EXCLUDE_FROM_ALL\\)")
-                            "find_package(mimalloc REQUIRED)")))))))
+                            "find_package(mimalloc REQUIRED)"))))
+                     (add-after 'install 'wrap-program
+                       (lambda* (#:key inputs outputs #:allow-other-keys)
+                         (wrap-program (string-append (assoc-ref outputs "out")
+                                                      "/bin/solvespace")
+                           ;; For GtkFileChooserDialog.
+                           `("GSETTINGS_SCHEMA_DIR" =
+                             (,(string-append (assoc-ref inputs "gtk+")
+                                              "/share/glib-2.0/schemas")))))))))
       (inputs (list cairo
                     eigen
                     freetype

base-commit: e3ed1d09f9d490eff6becd6e9cb85a4d36c48e85
-- 
2.37.3