diff mbox series

[bug#40102] gnu packages gnome-xyz: Add topicons-redux

Message ID AfbWxtOJaB86st91o0f6zA6uMBnHbUrirJKdjFVApSxoTaCVAkcmXNpB7rA1ChnAJ-3cC59q9xvWwVgrXxKao3onz-iE8wPzOSbOOhy1imc=@elenq.tech
State Accepted
Headers show
Series [bug#40102] gnu packages gnome-xyz: Add topicons-redux | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Ekaitz Zarraga March 20, 2020, 7:34 p.m. UTC
Hi all,

Thanks Marius for the feedback.

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
On Friday, March 20, 2020 5:53 PM, Marius Bakke <mbakke@fastmail.com> wrote:

> Such "autogenerated" tarballs from GitLab and GitHub are prone to
> getting re-created with different time stamps, breaking the checksum.
> Can you adjust this package to use git-fetch instead of url-fetch?

I wasn't aware of that! Thank you very much.


> Why are tests disabled? Please leave a comment.

Project doesn't have any test.


> Indentation is off here. If you are not using Emacs there is a script
> that can help with indentation, see "Formatting Code" in the Guix manual.

I'm using Vim with Vim paredit and it's own Sheme filetype, but it doesn't
work very well sometimes.


>
> The line break here is not necessary.

Solved

> > -   (synopsis "Displays legacy tray icons in the GNOME Shell top panel.
> >     +Rewritten fork of TopIcons Plus.")
> >
>
> Please keep synopsis to single sentences. The second sentence can be
> removed IMO.

Done.

> 'guix lint gnome-shell-extension-topicons-redux' will warn that
> sentences should be separated by two spaces. Can you adjust accordingly?

Done.

> > -   (license license:gpl2)))
>
> Is the license really GPL2 only? Unless the source code says explicitly
> "GPL2 only", this should probably be "gpl2+", i.e. "GPL2 or any later
> version".

Done.

>
> Can you send an updated patch?
>

Here it comes:


From e62251601732587409c18dfe3af0cd56ecf39d5f Mon Sep 17 00:00:00 2001
From: Ekaitz Zarraga <ekaitz@elenq.tech>
Date: Tue, 17 Mar 2020 13:54:24 +0100
Subject: [PATCH] gnu packages gnome-xyz: Add topicons-redux

---
 gnu/packages/gnome-xyz.scm | 43 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)

--
2.25.1

Comments

Marius Bakke March 21, 2020, 7:23 p.m. UTC | #1
Ekaitz Zarraga <ekaitz@elenq.tech> writes:

>> Indentation is off here. If you are not using Emacs there is a script
>> that can help with indentation, see "Formatting Code" in the Guix manual.
>
> I'm using Vim with Vim paredit and it's own Sheme filetype, but it doesn't
> work very well sometimes.

In that case, please run ./etc/indent-code.el before submitting
patches to lessen the burden on committers.  I've fixed the indentation
locally by running C-M-q in Emacs.

>>
>> Can you send an updated patch?
>>
>
> Here it comes:

Thanks!  Please add it as an attachment next time so the commit message
is preserved (or send the whole patch directly with 'git send-email').

Also, './pre-inst-env guix lint gnome-shell-extension-topicons-redux'
reported these issues:

gnu/packages/gnome-xyz.scm:155:5: gnome-shell-extension-topicons-redux@6: the source file name should contain the package name
gnu/packages/gnome-xyz.scm:181:14: gnome-shell-extension-topicons-redux@6: no period allowed at the end of the synopsis

I've fixed these locally too, sorry for missing them in the first
review.

Finally I edited the commit message so it follows our conventions.
Pushed in e7c7912573111d5e86f3e3012a6edab948f7b302.
Ekaitz Zarraga March 21, 2020, 7:34 p.m. UTC | #2
> I've fixed these locally too, sorry for missing them in the first
> review.
> ...

Sorry for all the work I gave you.
I'll do it better next time. Promise!

Thanks for your time.

Best,
Ekaitz
Marius Bakke March 21, 2020, 7:38 p.m. UTC | #3
Ekaitz Zarraga <ekaitz@elenq.tech> writes:

>> I've fixed these locally too, sorry for missing them in the first
>> review.
>> ...
>
> Sorry for all the work I gave you.
> I'll do it better next time. Promise!

No worries!  It takes a while to get the hang of these things.  :-)
diff mbox series

Patch

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index b8cd32db08..39579bbea4 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -4,6 +4,7 @@ 
 ;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;; Copyright © 2020 Alex Griffin <a@ajgrf.com>
 ;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
+;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -146,6 +147,48 @@  GNOME Shell.")
     (home-page "https://github.com/ubuntu/gnome-shell-extension-appindicator/")
     (license license:gpl2+)))

+(define-public gnome-shell-extension-topicons-redux
+  (package
+    (name "gnome-shell-extension-topicons-redux")
+    (version "6")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://gitlab.com/pop-planet/TopIcons-Redux.git")
+               (commit version)))
+        (sha256
+          (base32 "1dli9xb545n3xlj6q4wl0y5gzkm903zs47p8fiq71pdvbr6v38rj"))))
+    (build-system gnu-build-system)
+    (native-inputs
+      `(("glib" ,glib "bin")))
+    (arguments
+      `(#:tests? #f ; No test defined in the project
+        #:phases
+        (modify-phases
+          %standard-phases
+          (delete 'configure)
+          (delete 'build)
+          (replace 'install
+                   (lambda* (#:key outputs #:allow-other-keys)
+                     (let ((out (assoc-ref outputs "out")))
+                       (invoke "make"
+                               "install"
+                               (string-append
+                                 "INSTALL_PATH="
+                                 out
+                                 "/share/gnome-shell/extensions"))))))))
+
+    (home-page "https://gitlab.com/pop-planet/TopIcons-Redux/")
+    (synopsis "Displays legacy tray icons in the GNOME Shell top panel.")
+    (description "Many applications, such as chat clients, downloaders, and
+some media players, are meant to run long-term in the background even after you
+close their window.  These applications remain accessible by adding an icon to
+the GNOME Shell Legacy Tray.  However, the Legacy Tray was removed in GNOME
+3.26.  TopIcons Redux brings those icons back into the top panel so that it's
+easier to keep track of apps running in the backround.")
+    (license license:gpl2+)))
+
 (define-public gnome-shell-extension-dash-to-dock
   (package
     (name "gnome-shell-extension-dash-to-dock")