[bug#78526,v2] gnu: Add toolong.
Commit Message
* gnu/packages/admin.scm (toolong): New variable.
Change-Id: Iddecb5be0f53d0aaaf2143410f6083d08dddb9bf
---
gnu/packages/admin.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)
base-commit: 11bc17c409d77cd1af91e30b5b9f6a73f873a152
@@ -77,6 +77,7 @@
;;; Copyright © 2025 Dariqq <dariqq@posteo.net>
;;; Copyright © 2024 nik gaffney <nik@fo.am>
;;; Copyright © 2025 Simon Streit <simon@netpanic.org>
+;;; Copyright © 2025 Junker <dk@junkeria.club>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -985,6 +986,38 @@ (define-public facter
(home-page "https://github.com/puppetlabs/facter")
(license license:expat)))
+(define-public toolong
+ (package
+ (name "toolong")
+ (version "1.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "toolong" version))
+ (sha256
+ (base32 "1wxw7gprxpimzzqzqr8hpq5fmyrx1xpfs6rq6wfp1yalz40lg4s9"))))
+ (build-system pyproject-build-system)
+ (arguments (list #:tests? #f)) ;no tests
+ (propagated-inputs (list python-click
+ python-textual
+ python-typing-extensions))
+ (native-inputs
+ (list python-poetry-core))
+ (synopsis "Terminal application to view, tail, merge, and search log
+files (plus JSONL)")
+ (description "Toolong is a terminal application to view, tail, merge, and
+search log files (plus JSONL).
+@itemize
+@item Live tailing of log files.
+@item Syntax highlights common web server log formats.
+@item As fast to open a multiple-gigabyte file as it is to open a tiny text file.
+@item Support for JSONL files: lines are pretty printed.
+@item Opens .bz and .bz2 files automatically.
+@item Merges log files by auto detecting timestamps.
+@end itemize")
+ (home-page "https://github.com/textualize/toolong")
+ (license license:expat)))
+
(define-public ttyload
(let ((revision "1")
(commit "f9495372801ce4b4dad98ad854203e694c31c1eb"))