diff mbox series

[bug#70035,v3,1/9] gnu: openimageio: Update to 2.5.10.1.

Message ID 9c220bc0c340b0c3bd9f3e979ade8663a729b7db.1712107465.git.monego@posteo.net
State New
Headers show
Series Update and cleanup ASWF tools. | expand

Commit Message

Vinicius Monego April 3, 2024, 1:30 a.m. UTC
* gnu/packages/graphics.scm (openimageio): Update to 2.5.10.1.
[source]: Adjust tag prefix.
[arguments]: Use G-Expressions.
<#:configure-flags>: Pass "-DOIIO_BUILD_TESTS=false".
[inputs]: Replace openexr-2 with openexr, fmt-8 with fmt. Use package labels.

Change-Id: I7016f89c5b7c78cbc1ffeac23e5c0cefe2a8f43b
---
 gnu/packages/cpp.scm      |  2 +-
 gnu/packages/graphics.scm | 42 +++++++++++++++++++--------------------
 2 files changed, 21 insertions(+), 23 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index acbe3e4836..2c04920166 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -10,7 +10,7 @@ 
 ;;; Copyright © 2020 Roel Janssen <roel@gnu.org>
 ;;; Copyright © 2020, 2021, 2023, 2024 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
-;;; Copyright © 2020, 2021, 2022 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020, 2021, 2022, 2024 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2020, 2022 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index ad08141c96..23b6af066a 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1313,40 +1313,38 @@  (define-public openexr-2
 (define-public openimageio
   (package
     (name "openimageio")
-    (version "2.2.21.0")
+    (version "2.5.10.1")
     (source (origin
               (method git-fetch)
               (uri (git-reference
                     (url "https://github.com/OpenImageIO/oiio")
-                    (commit (string-append "Release-" version))))
+                    (commit (string-append "v" version))))
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0aicxbshzv1g9d8d08vsj1a9klaycxaifvvp565qjv70wyma2vkr"))))
+                "06x3lqj9qjh5m0zbr5g2g9ii6jk340pgzrhr4fb353y1y2pkx5sw"))))
     (build-system cmake-build-system)
-    ;; FIXME: To run all tests successfully, test image sets from multiple
-    ;; third party sources have to be present.  For details see
-    ;; <https://github.com/OpenImageIO/oiio/blob/master/INSTALL.md>
     (arguments
-     `(#:tests? #f
-       #:configure-flags (list "-DUSE_EXTERNAL_PUGIXML=1")))
+     (list #:tests? #f ; half the tests require online data or use redirection
+           #:configure-flags #~(list "-DUSE_EXTERNAL_PUGIXML=1"
+                                     "-DOIIO_BUILD_TESTS=false")))
     (native-inputs
      (list pkg-config))
     (inputs
-     `(("boost" ,boost)
-       ("fmt" ,fmt-8)
-       ("libheif" ,libheif)
-       ("libpng" ,libpng)
-       ("libjpeg" ,libjpeg-turbo)
-       ("libtiff" ,libtiff)
-       ("giflib" ,giflib)
-       ("openexr" ,openexr-2)
-       ("ilmbase" ,ilmbase)
-       ("pugixml" ,pugixml)
-       ("python" ,python-wrapper)
-       ("pybind11" ,pybind11)
-       ("robin-map" ,robin-map)
-       ("zlib" ,zlib)))
+     (list boost
+           fmt
+           libheif
+           libpng
+           libjpeg-turbo
+           libtiff
+           giflib
+           openexr
+           imath
+           pugixml
+           python-wrapper
+           pybind11
+           robin-map
+           zlib))
     (synopsis "C++ library for reading and writing images")
     (description
      "OpenImageIO is a library for reading and writing images, and a bunch of