diff mbox series

[bug#70035,v3,9/9] gnu: blender: Update to 3.6.10.

Message ID 6f9730b7537fc44d36c0b28db981919d16c3f965.1712107465.git.monego@posteo.net
State New
Headers show
Series Update and cleanup ASWF tools. | expand

Commit Message

Vinicius Monego April 3, 2024, 1:30 a.m. UTC
* gnu/packages/graphics.scm (blender): Update to 3.6.10.
[arguments]<#:configure-flags>: Unset "-DPYTHON_LIBRARY", "-DPYTHON_LIBPATH",
"-DPYTHON_VERSION", "-DPYTHON_NUMPY_INCLUDE_DIRS", "-DPYTHON_NUMPY_PATH",
"-DCMAKE_CXX_FLAGS".
[inputs]: Add libepoxy. Replace freetype with freetype-with-brotli, ilmbase
with imath, openexr-2 with openexr.

Change-Id: Ifb5e5cdb4d26aac9626bf5cd77e171d8b0ebfaed
---
 gnu/packages/graphics.scm | 43 +++++++--------------------------------
 1 file changed, 7 insertions(+), 36 deletions(-)

Comments

Vinicius Monego April 3, 2024, 10:04 p.m. UTC | #1
I reintroduced the configure flags removed from Blender, rebuilt it 
locally and it's building again, and the application launches. I will 
push the series in the coming days.

Em 02/04/2024 22:30, Vinicius Monego escreveu:
> * gnu/packages/graphics.scm (blender): Update to 3.6.10.
> [arguments]<#:configure-flags>: Unset "-DPYTHON_LIBRARY", "-DPYTHON_LIBPATH",
> "-DPYTHON_VERSION", "-DPYTHON_NUMPY_INCLUDE_DIRS", "-DPYTHON_NUMPY_PATH",
> "-DCMAKE_CXX_FLAGS".
> [inputs]: Add libepoxy. Replace freetype with freetype-with-brotli, ilmbase
> with imath, openexr-2 with openexr.
>
> Change-Id: Ifb5e5cdb4d26aac9626bf5cd77e171d8b0ebfaed
> ---
>   gnu/packages/graphics.scm | 43 +++++++--------------------------------
>   1 file changed, 7 insertions(+), 36 deletions(-)
>
> diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
> index 555800e517..fc99da8a12 100644
> --- a/gnu/packages/graphics.scm
> +++ b/gnu/packages/graphics.scm
> @@ -493,14 +493,14 @@ (define-public openvdb
>   (define-public blender
>     (package
>       (name "blender")
> -    (version "3.3.5")                   ;3.3.x is the current LTS version
> +    (version "3.6.10")                   ;3.6.x is the current LTS version
>       (source (origin
>                 (method url-fetch)
>                 (uri (string-append "https://download.blender.org/source/"
>                                     "blender-" version ".tar.xz"))
>                 (sha256
>                  (base32
> -                "1pwl4lbc00g0bj97rd8l9fnrv3w1gny9ci6mrma3pp2acgs56502"))))
> +                "1srwr365y40hhpjmfsg52rphdybvin0ay2r23pknm7b9pkpw0wqs"))))
>       (build-system cmake-build-system)
>       (arguments
>        (list
> @@ -520,48 +520,19 @@ (define-public blender
>                   "-DWITH_MOD_OCEANSIM=ON"
>                   "-DWITH_OPENVDB=ON"
>                   "-DWITH_OPENSUBDIV=ON"
> -                "-DWITH_PYTHON_INSTALL=OFF"
> -                (string-append "-DPYTHON_LIBRARY=python" #$python-version)
> -                (string-append "-DPYTHON_LIBPATH="
> -                               (assoc-ref %build-inputs "python")
> -                               "/lib")
> -                (string-append "-DPYTHON_INCLUDE_DIR="
> -                               (assoc-ref %build-inputs "python")
> -                               "/include/python" #$python-version)
> -                (string-append "-DPYTHON_VERSION=" #$python-version)
> -                (string-append "-DPYTHON_NUMPY_INCLUDE_DIRS="
> -                               (assoc-ref %build-inputs "python-numpy")
> -                               "/lib/python" #$python-version
> -                               "/site-packages/numpy/core/include/")
> -                (string-append "-DPYTHON_NUMPY_PATH="
> -                               (assoc-ref %build-inputs "python-numpy")
> -                               "/lib/python" #$python-version
> -                               "/site-packages/")
> -                ;; OpenEXR propagates ilmbase, but its include files do not
> -                ;; appear in the C_INCLUDE_PATH, so we need to add
> -                ;; "$ilmbase/include/OpenEXR/" to the C_INCLUDE_PATH to
> -                ;; satisfy the dependency on "half.h" and "Iex.h".
> -                (string-append "-DCMAKE_CXX_FLAGS=-I"
> -                               (search-input-directory %build-inputs
> -                                                       "include/OpenEXR"))))
> -      #:phases
> -      #~(modify-phases %standard-phases
> -          (add-after 'unpack 'fix-broken-import
> -            (lambda _
> -              (substitute* "release/scripts/addons/io_scene_fbx/json2fbx.py"
> -                (("import encode_bin")
> -                 "from . import encode_bin")))))))
> +                "-DWITH_PYTHON_INSTALL=OFF"))))
>       (inputs
>        (list boost
>              embree
>              ffmpeg-5
>              fftw
> -           freetype
> +           freetype-with-brotli
>              glew
>              gmp                        ;needed for boolean operations on meshes
> -           ilmbase
> +           imath
>              jack-1
>              jemalloc
> +           libepoxy
>              libjpeg-turbo
>              libpng
>              libsndfile
> @@ -571,7 +542,7 @@ (define-public blender
>              libxrender
>              openal
>              opencolorio
> -           openexr-2
> +           openexr
>              openimageio
>              openjpeg
>              opensubdiv
diff mbox series

Patch

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 555800e517..fc99da8a12 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -493,14 +493,14 @@  (define-public openvdb
 (define-public blender
   (package
     (name "blender")
-    (version "3.3.5")                   ;3.3.x is the current LTS version
+    (version "3.6.10")                   ;3.6.x is the current LTS version
     (source (origin
               (method url-fetch)
               (uri (string-append "https://download.blender.org/source/"
                                   "blender-" version ".tar.xz"))
               (sha256
                (base32
-                "1pwl4lbc00g0bj97rd8l9fnrv3w1gny9ci6mrma3pp2acgs56502"))))
+                "1srwr365y40hhpjmfsg52rphdybvin0ay2r23pknm7b9pkpw0wqs"))))
     (build-system cmake-build-system)
     (arguments
      (list
@@ -520,48 +520,19 @@  (define-public blender
                 "-DWITH_MOD_OCEANSIM=ON"
                 "-DWITH_OPENVDB=ON"
                 "-DWITH_OPENSUBDIV=ON"
-                "-DWITH_PYTHON_INSTALL=OFF"
-                (string-append "-DPYTHON_LIBRARY=python" #$python-version)
-                (string-append "-DPYTHON_LIBPATH="
-                               (assoc-ref %build-inputs "python")
-                               "/lib")
-                (string-append "-DPYTHON_INCLUDE_DIR="
-                               (assoc-ref %build-inputs "python")
-                               "/include/python" #$python-version)
-                (string-append "-DPYTHON_VERSION=" #$python-version)
-                (string-append "-DPYTHON_NUMPY_INCLUDE_DIRS="
-                               (assoc-ref %build-inputs "python-numpy")
-                               "/lib/python" #$python-version
-                               "/site-packages/numpy/core/include/")
-                (string-append "-DPYTHON_NUMPY_PATH="
-                               (assoc-ref %build-inputs "python-numpy")
-                               "/lib/python" #$python-version
-                               "/site-packages/")
-                ;; OpenEXR propagates ilmbase, but its include files do not
-                ;; appear in the C_INCLUDE_PATH, so we need to add
-                ;; "$ilmbase/include/OpenEXR/" to the C_INCLUDE_PATH to
-                ;; satisfy the dependency on "half.h" and "Iex.h".
-                (string-append "-DCMAKE_CXX_FLAGS=-I"
-                               (search-input-directory %build-inputs
-                                                       "include/OpenEXR"))))
-      #:phases
-      #~(modify-phases %standard-phases
-          (add-after 'unpack 'fix-broken-import
-            (lambda _
-              (substitute* "release/scripts/addons/io_scene_fbx/json2fbx.py"
-                (("import encode_bin")
-                 "from . import encode_bin")))))))
+                "-DWITH_PYTHON_INSTALL=OFF"))))
     (inputs
      (list boost
            embree
            ffmpeg-5
            fftw
-           freetype
+           freetype-with-brotli
            glew
            gmp                        ;needed for boolean operations on meshes
-           ilmbase
+           imath
            jack-1
            jemalloc
+           libepoxy
            libjpeg-turbo
            libpng
            libsndfile
@@ -571,7 +542,7 @@  (define-public blender
            libxrender
            openal
            opencolorio
-           openexr-2
+           openexr
            openimageio
            openjpeg
            opensubdiv