diff mbox series

[bug#68500,v1,1/2] gnu: qtscxml: Update to 6.5.2.

Message ID 9b0b983a7d860ae24e0d3bf9eff0e62a301573a1.1705523575.git.sarg@sarg.org.ru
State New
Headers show
Series gnu: ausweisapp: Update to 2.0.2. | expand

Commit Message

Sergey Trofimov Jan. 17, 2024, 8:36 p.m. UTC
* gnu/packages/qt.scm (qtscxml): Update to 6.5.2.
(qtscxml-5): Add qt5 variant.
(python-pyside-2)[inputs]: Use qtscxml-5.
---
 gnu/packages/qt.scm | 43 +++++++++++++++++++++++++++++++++++++++++--
 1 file changed, 41 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 2b89e7e738..febffff90e 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2316,7 +2316,7 @@  (define-public qtgamepad
 primary target audience are embedded devices with fullscreen user interfaces,
 and mobile applications targeting TV-like form factors.")))
 
-(define-public qtscxml
+(define-public qtscxml-5
   (package
     (inherit qtsvg-5)
     (name "qtscxml")
@@ -2344,6 +2344,45 @@  (define-public qtscxml
 generating a C++ file that has a class implementing the state machine.  It
 also contains functionality to support data models and executable content.")))
 
+(define-public qtscxml
+  (package
+    (name "qtscxml")
+    (version "6.5.2")
+    (source (origin
+              (method url-fetch)
+              (uri (qt-url name version))
+              (sha256
+               (base32
+                "1jxx9p7zi40r990ky991xd43mv6i8hdpnj2fhl7sf4q9fpng4c58"))
+              (modules '((guix build utils)))
+              (snippet
+               '(begin
+                  (delete-file-recursively "tests/3rdparty")))))
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (delete 'check)               ;move after the install phase
+          (add-after 'install 'check
+            (assoc-ref %standard-phases 'check))
+          (add-before 'check 'check-setup
+            (lambda _
+              (setenv "ARGS" "-E tst_scion")
+              (setenv "QT_QPA_PLATFORM" "offscreen")
+              (setenv "QML2_IMPORT_PATH"
+                      (string-append #$output "/lib/qt6/qml:"
+                                     (getenv "QML2_IMPORT_PATH"))))))))
+    (build-system cmake-build-system)
+    (inputs (list qtbase qtdeclarative libxkbcommon))
+    (synopsis "Qt SCXML module")
+    (description "The Qt SCXML module provides functionality to create state
+machines from SCXML files.  This includes both dynamically creating state
+machines (loading the SCXML file and instantiating states and transitions) and
+generating a C++ file that has a class implementing the state machine.  It
+also contains functionality to support data models and executable content.")
+    (home-page (package-home-page qtbase))
+    (license (package-license qtbase))))
+
 (define-public qtpositioning
   (package
     (name "qtpositioning")
@@ -4453,7 +4492,7 @@  (define-public python-pyside-2
            qtquickcontrols-5
            qtquickcontrols2-5
            qtscript
-           qtscxml
+           qtscxml-5
            qtsensors
            qtspeech
            qtsvg-5