diff mbox series

[bug#68500,v1,2/2] gnu: ausweisapp: Update to 2.0.2.

Message ID 43f4cf2137ecab47a33b001cb714b9539e6f25ae.1705523575.git.sarg@sarg.org.ru
State New
Headers show
Series gnu: ausweisapp: Update to 2.0.2. | expand

Commit Message

Sergey Trofimov Jan. 17, 2024, 8:36 p.m. UTC
* gnu/packages/security-token.scm (ausweisapp): Update to 2.0.2.
(ausweisapp2): Rename to ausweisapp.
---
 gnu/packages/security-token.scm | 45 ++++++++++++++++-----------------
 1 file changed, 22 insertions(+), 23 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index a1fc058db8..34ae6ea215 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -950,43 +950,42 @@  (define-public nitrocli
 devices.")
     (license license:gpl3+)))
 
-(define-public ausweisapp2
+(define-public ausweisapp
   (package
-    (name "ausweisapp2")
-    (version "1.22.2")
+    (name "ausweisapp")
+    (version "2.0.2")
     (source (origin
               (method url-fetch)
-              (uri (string-append "https://github.com/Governikus/AusweisApp2/releases"
-                                  "/download/" version "/AusweisApp2-" version ".tar.gz"))
+              (uri (string-append "https://github.com/Governikus/AusweisApp/releases"
+                                  "/download/" version "/AusweisApp-" version ".tar.gz"))
               (sha256
                (base32
-                "1qh1m057va7njs3yk0s31kwsvv44fjlsdac6lhiw5npcwssgjn8l"))))
+                "1y0bnp8ry9x7nmf6akx9gfpx91p3x15jh72yrzpfpll6zmppcx3b"))))
 
-    (build-system cmake-build-system)
+    (build-system qt-build-system)
     (native-inputs
-     (list pkg-config qttools-5))
+     (list pkg-config qttools))
     (inputs
-     (list qtbase-5
-           qtsvg-5
-           qtdeclarative-5
-           qtwebsockets-5
+     (list qtbase
+           qtsvg
+           qtscxml
+           qtdeclarative
+           qtshadertools
+           qtwebsockets
            qtgraphicaleffects
-           qtquickcontrols2-5
            pcsc-lite
            openssl))
     (arguments
-     `(#:modules ((guix build cmake-build-system)
-                  (guix build qt-utils)
-                  (guix build utils))
-       #:imported-modules (,@%cmake-build-system-modules
-                           (guix build qt-utils))
+     `(#:qtbase ,qtbase
        #:phases
        (modify-phases %standard-phases
-         (add-after 'install 'wrap-qt
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out")))
-               (wrap-qt-program "AusweisApp2" #:output out #:inputs inputs)))))))
-    (home-page "https://github.com/Governikus/AusweisApp2")
+         (replace 'check
+           (lambda* (#:key tests? parallel-tests? #:allow-other-keys)
+             (when tests? (invoke "ctest" "--output-on-failure" "-j"
+                                  (if parallel-tests?
+                                      (number->string (parallel-job-count))
+                                      "1"))))))))
+    (home-page "https://github.com/Governikus/AusweisApp")
     (synopsis
      "Authentication program for German ID cards and residence permits")
     (description