diff mbox series

[bug#63854,core-updates,v2,2/2] gnu: po4a: Fix SGML tests.

Message ID 99dd54ed52c714945eff265946160f2c682f2899.1685879572.git.gemmaro.dev@gmail.com
State New
Headers show
Series gnu: po4a: Fix SGML tests. | expand

Commit Message

gemmaro June 4, 2023, 12:28 p.m. UTC
* gnu/packages/gettext.scm (po4a)
[arguments]: Fix SGML tests.
[native-inputs]: Add docbook-sgml-4.1.
[inputs]: Add opensp.
---
 gnu/packages/gettext.scm | 12 +++++-------
 1 file changed, 5 insertions(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index 9387f4fb8a5..382c1d8e93e 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -11,7 +11,7 @@ 
 ;;; Copyright © 2019 Miguel <rosen644835@gmail.com>
 ;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
 ;;; Copyright © 2020 EuAndreh <eu@euandre.org>
-;;; Copyright © 2022 gemmaro <gemmaro.dev@gmail.com>
+;;; Copyright © 2022, 2023 gemmaro <gemmaro.dev@gmail.com>
 ;;; Copyright © 2023 Maxim Cournoyer maxim.cournoyer@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -279,23 +279,21 @@  (define-public po4a
                 (for-each (lambda (file)
                             (wrap-program file
                               `("PERL5LIB" ":" prefix (,path))))
-                          (find-files bin "\\.*$")))))
-          (add-before 'check 'disable-failing-tests
-            (lambda _
-              ;; FIXME: fails despite of importing SGMLS
-              (delete-file "t/fmt-sgml.t"))))))
+                          (find-files bin "\\.*$"))))))))
     (native-inputs
      (list gettext-minimal
            perl-module-build
            docbook-xsl
-           libxml2
+           libxml2 ;for SGML_CATALOG_FILES
            libxslt
            ;; For tests.
+           docbook-sgml-4.1
            docbook-xml-4.1.2
            perl-test-pod
            texlive-tiny))
     (inputs
      (list bash-minimal
+           opensp
            perl-gettext
            perl-pod-parser
            perl-sgmls