diff mbox series

[bug#63854,core-updates,v2,1/2] gnu: libxml2: Add SGML_CATALOG_FILES to native-search-path.

Message ID 72b82f75a3f87474a3eb40486fd01db09ee97ebd.1685879572.git.gemmaro.dev@gmail.com
State New
Headers show
Series gnu: po4a: Fix SGML tests. | expand

Commit Message

gemmaro June 4, 2023, 12:28 p.m. UTC
* gnu/packages/xml.scm
(libxml2)[native-search-paths]: Add SGML_CATALOG_FILES.
(opensp)[native-search-paths]: Remove SGML_CATALOG_FILES.
---
 gnu/packages/xml.scm | 37 ++++++++++++++++++++-----------------
 1 file changed, 20 insertions(+), 17 deletions(-)

Comments

Bruno Victal June 8, 2023, 6:46 p.m. UTC | #1
Hi gemmaro,

On 2023-06-04 13:28, gemmaro wrote:
> * gnu/packages/xml.scm
> (libxml2)[native-search-paths]: Add SGML_CATALOG_FILES.
> (opensp)[native-search-paths]: Remove SGML_CATALOG_FILES.

[…]

> @@ -1781,14 +1792,6 @@ (define-public opensp
>                  (("^\tOSGMLNORM=`echo osgmlnorm\\|sed '\\$\\(transform\\)'`\\\\")
>                   "\tOSGMLNORM=`echo osgmlnorm|sed '$(transform)'`")
>                  (("^\t\\$\\(SHELL\\)\n") "")))))))
> -    ;; $SGML_CATALOG_FILES lists 'catalog' or 'CATALOG' or '*.cat' files found
> -    ;; under the 'sgml' sub-directory of any given package.
> -    (native-search-paths (list (search-path-specification
> -                                (variable "SGML_CATALOG_FILES")
> -                                (separator ":")
> -                                (files '("sgml"))
> -                                (file-pattern "^catalog$|^CATALOG$|^.*\\.cat$")
> -                                (file-type 'regular))))

Interesting, looking at opensp it seems that it also makes use of the
SGML_CATALOG_FILES environment variable so I don't think it shouldn't
be removed though I don't know if it's valid for more than one package
to share the same native-search-path.

Maybe someone else can weigh in?
Maxim Cournoyer Sept. 6, 2023, 2:05 p.m. UTC | #2
Hi,

Bruno Victal <mirai@makinata.eu> writes:

> Hi gemmaro,
>
> On 2023-06-04 13:28, gemmaro wrote:
>> * gnu/packages/xml.scm
>> (libxml2)[native-search-paths]: Add SGML_CATALOG_FILES.
>> (opensp)[native-search-paths]: Remove SGML_CATALOG_FILES.
>
> […]
>
>> @@ -1781,14 +1792,6 @@ (define-public opensp
>>                  (("^\tOSGMLNORM=`echo osgmlnorm\\|sed '\\$\\(transform\\)'`\\\\")
>>                   "\tOSGMLNORM=`echo osgmlnorm|sed '$(transform)'`")
>>                  (("^\t\\$\\(SHELL\\)\n") "")))))))
>> -    ;; $SGML_CATALOG_FILES lists 'catalog' or 'CATALOG' or '*.cat' files found
>> -    ;; under the 'sgml' sub-directory of any given package.
>> -    (native-search-paths (list (search-path-specification
>> -                                (variable "SGML_CATALOG_FILES")
>> -                                (separator ":")
>> -                                (files '("sgml"))
>> -                                (file-pattern "^catalog$|^CATALOG$|^.*\\.cat$")
>> -                                (file-type 'regular))))
>
> Interesting, looking at opensp it seems that it also makes use of the
> SGML_CATALOG_FILES environment variable so I don't think it shouldn't
> be removed though I don't know if it's valid for more than one package
> to share the same native-search-path.

The search paths are not currently 'merged', but if they are exactly
defined the same way (could by via a $SGML_CATALOG_FILES export
defininition (guix search-paths)) then it should work normally.
Bruno Victal Sept. 6, 2023, 2:28 p.m. UTC | #3
Hi Maxim,

On 2023-09-06 15:05, Maxim Cournoyer wrote:
>> Interesting, looking at opensp it seems that it also makes use of the
>> SGML_CATALOG_FILES environment variable so I don't think it shouldn't
>> be removed though I don't know if it's valid for more than one package
>> to share the same native-search-path.
> 
> The search paths are not currently 'merged', but if they are exactly
> defined the same way (could by via a $SGML_CATALOG_FILES export
> defininition (guix search-paths)) then it should work normally.

Indeed, this is what I'm doing in 12/61 from the #65479-v1 [1] patch
series. (hence the partial integration mentioned in the cover letter)


[1]: <https://issues.guix.gnu.org/65479>
Maxim Cournoyer Sept. 6, 2023, 6:44 p.m. UTC | #4
Hi,

Bruno Victal <mirai@makinata.eu> writes:

> Hi Maxim,
>
> On 2023-09-06 15:05, Maxim Cournoyer wrote:
>>> Interesting, looking at opensp it seems that it also makes use of the
>>> SGML_CATALOG_FILES environment variable so I don't think it shouldn't
>>> be removed though I don't know if it's valid for more than one package
>>> to share the same native-search-path.
>> 
>> The search paths are not currently 'merged', but if they are exactly
>> defined the same way (could by via a $SGML_CATALOG_FILES export
>> defininition (guix search-paths)) then it should work normally.
>
> Indeed, this is what I'm doing in 12/61 from the #65479-v1 [1] patch
> series. (hence the partial integration mentioned in the cover letter)
>
>
> [1]: <https://issues.guix.gnu.org/65479>

OK, excellent.
diff mbox series

Patch

diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 8d9974b825c..c19e7125647 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -33,6 +33,7 @@ 
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2021 David Larsson <david.larsson@selfhosted.xyz>
 ;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
+;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -222,14 +223,24 @@  (define-public libxml2
     (inputs (list xz))
     (propagated-inputs (list zlib)) ; libxml2.la says '-lz'.
     (native-inputs (list perl))
-    ;; $XML_CATALOG_FILES lists 'catalog.xml' files found in under the 'xml'
-    ;; sub-directory of any given package.
-    (native-search-paths (list (search-path-specification
-                                (variable "XML_CATALOG_FILES")
-                                (separator " ")
-                                (files '("xml"))
-                                (file-pattern "^catalog\\.xml$")
-                                (file-type 'regular))))
+    (native-search-paths
+     (list
+      ;; $XML_CATALOG_FILES lists 'catalog.xml' files found in under the 'xml'
+      ;; sub-directory of any given package.
+      (search-path-specification
+       (variable "XML_CATALOG_FILES")
+       (separator " ")
+       (files '("xml"))
+       (file-pattern "^catalog\\.xml$")
+       (file-type 'regular))
+      ;; $SGML_CATALOG_FILES lists 'catalog' or 'CATALOG' or '*.cat' files found
+      ;; under the 'sgml' sub-directory of any given package.
+      (search-path-specification
+       (variable "SGML_CATALOG_FILES")
+       (separator ":")
+       (files '("sgml"))
+       (file-pattern "^catalog$|^CATALOG$|^.*\\.cat$")
+       (file-type 'regular))))
     (search-paths native-search-paths)
     (description
      "Libxml2 is the XML C parser and toolkit developed for the Gnome
@@ -1743,7 +1754,7 @@  (define-public opensp
     (native-inputs
      (list docbook-xml-4.1.2
            docbook-xsl
-           libxml2                      ;for XML_CATALOG_DIR
+           libxml2 ;for XML_CATALOG_FILES and SGML_CATALOG_FILES
            xmlto
            ;; Dependencies to regenerate the 'configure' script.
            autoconf
@@ -1781,14 +1792,6 @@  (define-public opensp
                 (("^\tOSGMLNORM=`echo osgmlnorm\\|sed '\\$\\(transform\\)'`\\\\")
                  "\tOSGMLNORM=`echo osgmlnorm|sed '$(transform)'`")
                 (("^\t\\$\\(SHELL\\)\n") "")))))))
-    ;; $SGML_CATALOG_FILES lists 'catalog' or 'CATALOG' or '*.cat' files found
-    ;; under the 'sgml' sub-directory of any given package.
-    (native-search-paths (list (search-path-specification
-                                (variable "SGML_CATALOG_FILES")
-                                (separator ":")
-                                (files '("sgml"))
-                                (file-pattern "^catalog$|^CATALOG$|^.*\\.cat$")
-                                (file-type 'regular))))
     (home-page "https://openjade.sourceforge.net/")
     (synopsis "Suite of SGML/XML processing tools")
     (description "OpenSP is an object-oriented toolkit for SGML parsing and