@@ -5371,6 +5371,37 @@ (define-public suitesparse-cholmod
and other related operations.")
(license (list license:gpl2+ license:lgpl2.1+))))
+(define-public suitesparse-cxsparse
+ (package
+ (name "suitesparse-cxsparse")
+ (version "4.2.0")
+ (source (suitesparse-package-src name "CXSparse"))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'set-cmake-module-path
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("set.*CMAKE_MODULE_PATH.*")
+ (string-append "set(CMAKE_MODULE_PATH "
+ #$suitesparse-config "/lib/cmake/SuiteSparse)\n"
+ "set(DUMMY\n")))))
+ (replace 'install-license-files
+ (lambda _
+ (let ((out (string-append #$output
+ "/share/doc/" #$name "-" #$version)))
+ (install-file "../source/Doc/License.txt" out)
+ (install-file "../source/Doc/lesser.txt" out)))))))
+ (inputs (list suitesparse-config))
+ (home-page "https://people.engr.tamu.edu/davis/suitesparse.html")
+ (synopsis "Concise eXtended Sparse Matrix Package")
+ (description "CXSparse is a collection of sparse matrix algorithms for
+direct methods on both real and complex matrices.")
+ (license license:lgpl2.1+)))
+
(define-public suitesparse
(package
(name "suitesparse")