diff mbox series

[bug#66129,v2,16/20] gnu: Add suitesparse-rbio.

Message ID 95023c251b41004544b43f1fa543b5b258d4417d.1695302719.git.david.elsing@posteo.net
State New
Headers show
Series [bug#66129,v2,01/20] gnu: suitesparse: Tweak description. | expand

Commit Message

David Elsing Sept. 21, 2023, 1:27 p.m. UTC
* gnu/packages/maths.scm (suitesparse-rbio): New variable.
---
 gnu/packages/maths.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 1121f09b22..2b7f7ef0ef 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5514,6 +5514,41 @@  (define-public suitesparse-ldl
 code.")
     (license license:lgpl2.1+)))
 
+(define-public suitesparse-rbio
+  (package
+    (name "suitesparse-rbio")
+    (version "4.2.0")
+    (source (suitesparse-package-src name "RBio"))
+    (build-system cmake-build-system)
+    (arguments
+     (list
+      #:tests? #f
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'set-cmake-module-path
+            (lambda _
+              (substitute* "CMakeLists.txt"
+                (("set.*CMAKE_MODULE_PATH.*")
+                 (string-append
+                  "set(CMAKE_MODULE_PATH "
+                  (string-join
+                   (map (lambda (path)
+                          (string-append path "/lib/cmake/SuiteSparse"))
+                        (list #$suitesparse-config)))
+                  ")\nset(DUMMY\n")))))
+          (replace 'install-license-files
+            (lambda _
+              (let ((out (string-append #$output
+                                        "/share/doc/" #$name "-" #$version)))
+                (install-file "../source/Doc/License.txt" out)
+                (install-file "../source/Doc/gpl.txt" out)))))))
+    (inputs (list suitesparse-config))
+    (home-page "https://people.engr.tamu.edu/davis/suitesparse.html")
+    (synopsis "Library for the Rutherford/Boeing sparse matrix format")
+    (description "This package provides the C library of RBio.  It can be used
+for reading and writing sparse matrices in the Rutherford/Boeing format.")
+    (license license:gpl2+)))
+
 (define-public suitesparse
   (package
     (name "suitesparse")