diff mbox series

[bug#64012,v4,3/3] gnu: itstool: Add version depending on needed fix

Message ID 97f8a6028983576e26d877f0793c3b3c46d627a4.1686722470.git.atai@atai.org
State New
Headers show
Series [bug#64012,v4,1/3] gnu: libxml2: Add version 2.11.4 | expand

Commit Message

Andy Tai June 14, 2023, 6:04 a.m. UTC
* gnu/packages/glib.scm (itstool-with-utf8-fix): New variable
  [inputs]: Switch to libxml2-next and python-libxml2-next
---
 gnu/packages/glib.scm | 12 ++++++++++++
 1 file changed, 12 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index e988e8dc87..c0df750b9b 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -705,6 +705,18 @@  (define itstool
 translated.")
     (license license:gpl3+)))
 
+
+;; libxml2-next contains upstream fix for itstool crash on UTF-8 data
+;; https://gitlab.gnome.org/GNOME/libxml2/-/commit/76c6da420923f2721a2e16adfcef8707a2454a1b
+;; so we need to have an itstool based the new libxml2 version
+;; for itstool to avoid crash
+(define-public itstool-with-utf8-fix
+  (package/inherit itstool
+    (name "itstool-with-utf8-fix")
+    (inputs
+     (list libxml2-next python-libxml2-next python))))
+
+
 (define dbus-glib
   (package
     (name "dbus-glib")