diff mbox series

[bug#64012,v4,1/3] gnu: libxml2: Add version 2.11.4

Message ID 3afe9802dd9c7006c4164c28169feb983c43be42.1686722470.git.atai@atai.org
State New
Headers show
Series [bug#64012,v4,1/3] gnu: libxml2: Add version 2.11.4 | expand

Commit Message

Andy Tai June 14, 2023, 6:04 a.m. UTC
* gnu/packages/xml.scm (libxml2-next): Version 2.11.4 as new variable
---
 gnu/packages/xml.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: 6fe9a004dba2d4ddf69ff6f1714af15ffaa7e62a
diff mbox series

Patch

diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 8d9974b825..eaaa93fe14 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -191,6 +191,9 @@  (define-public libxml2
              (sha256
               (base32
                "1vnzk33wfms348lgz9pvkq9li7jm44pvm73lbr3w1khwgljlmmv0"))))
+                     ;; TODO: remove once migrated to libxml2-next as upstream has
+                     ;; proper fix in libxml2 2.11.4
+                     ;; defined as libxml2-next below for now
     (build-system gnu-build-system)
     (outputs '("out" "static" "doc"))
     (arguments
@@ -249,6 +252,25 @@  (define-public libxml2-xpath0
 provides an @code{--xpath0} option to @command{xmllint} that enables it
 to output XPath results with a null delimiter.")))
 
+
+;; libxml2-next contains upstream fix for itstool crash on UTF-8 data
+;; https://gitlab.gnome.org/GNOME/libxml2/-/commit/76c6da420923f2721a2e16adfcef8707a2454a1b
+;; so we need to being in the new libxml2 version
+;; for itstool to depend on to avoid crash
+(define-public libxml2-next
+  (package/inherit libxml2
+    (version "2.11.4")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://download.gnome.org/sources/libxml2/"
+                    (version-major+minor version) "/libxml2-" version
+                    ".tar.xz"))
+              (sha256 (base32
+                       "1xspgyswllk26g7jg95pnkfk1gqpzna28fm1kir3kwdki9ziszkk"))))
+    (native-inputs (list perl python-minimal-wrapper pkg-config))))
+
+
 (define-public python-libxml2
   (package/inherit libxml2
     (name "python-libxml2")