diff mbox series

[bug#70656,python-team,4/4] gnu: python-versioneer: Use git-minimal/pinned.

Message ID 96befd0df7df11d0e5750bd3408e58db13e6c10e.1714423249.git.mail@cbaines.net
State New
Headers show
Series Use git-minimal/pinned for some Python packages | expand

Commit Message

Christopher Baines April 29, 2024, 8:40 p.m. UTC
This helps reduce the dependencies on git, as I think it's find to build with
a slightly older git, at least during periods when git-minimal/pinned needs
updating.

* gnu/packages/version-control.scm (python-versioneer)[propagated-inputs]: Use
git-minimal/pinned.

Change-Id: Id537baa8228afeb3b84161ecb5fea0d131b45442
---
 gnu/packages/python-xyz.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 16b47d0aa7..b5a2197a0a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31915,7 +31915,7 @@  (define-public python-versioneer
                 (invoke "pycodestyle" "--max-line-length=88"
                         "git_version.py" "versioneer.py")))))))
     (native-inputs
-     (list git python-flake8 python-pycodestyle python-pyflakes))
+     (list git-minimal/pinned python-flake8 python-pycodestyle python-pyflakes))
     (propagated-inputs
      (list python-tomli))
     (home-page "https://github.com/python-versioneer/python-versioneer")