diff mbox series

[bug#70656,python-team,3/4] gnu: python-pbr: Use git-minimal/pinned.

Message ID 6fa03e8699d230e078f4e40c22cd637b3c18f768.1714423249.git.mail@cbaines.net
State New
Headers show
Series Use git-minimal/pinned for some Python packages | expand

Commit Message

Christopher Baines April 29, 2024, 8:40 p.m. UTC
This helps reduce the dependencies on git, as I think it's find to build with
a slightly older git, at least during periods when git-minimal/pinned needs
updating.

* gnu/packages/version-control.scm (python-pbr)[propagated-inputs]: Use
git-minimal/pinned.

Change-Id: Ib90056a1a603e06a99b5c601f9fcba7375dc24ac
---
 gnu/packages/python-xyz.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Lars-Dominik Braun May 4, 2024, 8:12 a.m. UTC | #1
Hi,

> This helps reduce the dependencies on git, as I think it's find to build with
> a slightly older git, at least during periods when git-minimal/pinned needs
> updating.

this one is used on the repository cloned during build. As far as I see
we use git-minimal for cloning. Do we know whether the on-disk structures
of git are stable, i.e. can a clone of git version A be read by a git
version B with B < A?

Lars
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f22b891ba5..16b47d0aa7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5128,7 +5128,7 @@  (define-public python-pbr
     (arguments
      `(#:tests? #f)) ;; Most tests seem to use the Internet.
     (propagated-inputs
-      (list git)) ;; pbr actually uses the "git" binary.
+      (list git-minimal/pinned)) ;; pbr actually uses the "git" binary.
     (native-inputs
       `(("python-fixtures" ,python-fixtures-bootstrap)
         ;; discover, coverage, hacking, subunit