@@ -5463,6 +5463,57 @@ (define-public suitesparse-klu
for real and complex matrices.")
(license license:lgpl2.1+)))
+(define-public suitesparse-ldl
+ (package
+ (name "suitesparse-ldl")
+ (version "3.2.0")
+ (source (suitesparse-package-src name "LDL"))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'set-cmake-module-path
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("set.*CMAKE_MODULE_PATH.*")
+ (string-append
+ "set(CMAKE_MODULE_PATH "
+ (string-join
+ (map (lambda (path)
+ (string-append path "/lib/cmake/SuiteSparse"))
+ (list #$suitesparse-amd
+ #$suitesparse-config)))
+ ")\nset(DUMMY\n")))))
+ (add-after 'build 'build-doc
+ (lambda _
+ (substitute* "../source/Doc/Makefile"
+ (("\\.\\./\\.\\./BTF/Include/btf.h")
+ (string-append #$suitesparse-btf "/include/btf.h")))
+ (with-directory-excursion "../source/Doc"
+ (invoke "make"))))
+ (add-after 'install 'install-doc
+ (lambda _
+ (install-file "../source/Doc/ldl_userguide.pdf"
+ (string-append #$output "/share/doc/"
+ #$name "-" #$version))))
+ (replace 'install-license-files
+ (lambda _
+ (install-file "../source/Doc/License.txt"
+ (string-append #$output "/share/doc/"
+ #$name "-" #$version)))))))
+ (inputs
+ (list suitesparse-amd
+ suitesparse-config))
+ (native-inputs (list (texlive-updmap.cfg '())))
+ (home-page "https://people.engr.tamu.edu/davis/suitesparse.html")
+ (synopsis "LDL' factorization method for sparse, symmetric matrices")
+ (description "This package contains a set of routines for computing the
+LDL' factorization of sparse, symmetric matrices. Its focus lies on concise
+code.")
+ (license license:lgpl2.1+)))
+
(define-public suitesparse
(package
(name "suitesparse")