diff mbox series

[bug#64486,v2,09/22] gnu: Add perl-string-license.

Message ID 8ff0e18940ad9ef47cb082ef3908e130f68dcda5.1698160401.git.mirai@makinata.eu
State New
Headers show
Series Update licensecheck to 3.3.9. | expand

Commit Message

Bruno Victal Oct. 24, 2023, 3:15 p.m. UTC
* gnu/packages/license.scm (perl-string-license): New variable.
---
 gnu/packages/license.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/license.scm b/gnu/packages/license.scm
index ca8375d19d..b619c80d1d 100644
--- a/gnu/packages/license.scm
+++ b/gnu/packages/license.scm
@@ -4,6 +4,7 @@ 
 ;;; Copyright © 2020, 2021 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2021 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;; Copyright © 2022 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -23,6 +24,7 @@ 
 (define-module (gnu packages license)
   #:use-module (gnu packages)
   #:use-module (gnu packages check)
+  #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages perl-check)
   #:use-module (gnu packages python-build)
@@ -89,6 +91,38 @@  (define-public perl-string-copyright
 statements and serializes in normalized format.")
     (license gpl3+)))
 
+(define-public perl-string-license
+  (package
+    (name "perl-string-license")
+    (version "0.0.9")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://cpan/authors/id/J/JO/JONASS/String-License-v"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "1dbw8rgwdlgnlvscijpb2dnw5irfd6wvca587bprq5kk19mf7jzf"))))
+    (build-system perl-build-system)
+    (native-inputs (list perl-file-basedir
+                         perl-regexp-pattern-license
+                         perl-software-license
+                         perl-test-without-module
+                         perl-test2-suite
+                         perl-yaml-libyaml))
+    (propagated-inputs (list perl-array-intspan
+                             perl-feature-compat-class
+                             perl-log-any
+                             perl-namespace-clean
+                             perl-path-tiny
+                             perl-regexp-pattern
+                             perl-regexp-pattern-license))
+    (home-page "https://metacpan.org/release/String-License")
+    (synopsis "Detect source code license statements in a text string")
+    (description "@code{String::License} identifies license statements in a
+string and serializes them in a normalized format.")
+    (license agpl3+)))
+
 (define-public perl-software-license
   (package
     (name "perl-software-license")