diff mbox series

[bug#64486,v2,01/22] gnu: Add perl-xs-parse-sublike.

Message ID 3707c85abf261ec7f7ea31510934654743826b76.1698160401.git.mirai@makinata.eu
State New
Headers show
Series Update licensecheck to 3.3.9. | expand

Commit Message

Bruno Victal Oct. 24, 2023, 3:15 p.m. UTC
* gnu/packages/perl.scm (perl-xs-parse-sublike): New variable.
---
 gnu/packages/perl.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 8b82c272fc..e5f535d039 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -37,6 +37,7 @@ 
 ;;; Copyright © 2023 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
 ;;; Copyright © 2023 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2023 Jake Leporte <jakeleporte@outlook.com>
+;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -11844,6 +11845,27 @@  (define-public perl-xs-parse-keyword
 keyword plugins using the @code{PL_keyword_plugin} hook mechanism.")
     (license (package-license perl))))
 
+(define-public perl-xs-parse-sublike
+  (package
+    (name "perl-xs-parse-sublike")
+    (version "0.18")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://cpan/authors/id/P/PE/PEVANS/XS-Parse-Sublike-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "0m2iv6sfkkj6ckx7nprniqrj5qg2qyir8ns8l2rwmqnvxw2pqq16"))))
+    (build-system perl-build-system)
+    (native-inputs (list perl-module-build perl-test2-suite))
+    (home-page "https://metacpan.org/release/XS-Parse-Sublike")
+    (synopsis "XS functions to assist in parsing sub-like syntax")
+    (description "This module provides some XS functions to assist in writing
+parsers for @code{sub}-like syntax, primarily for authors of keyword plugins
+using the @code{PL_keyword_plugin} hook mechanism.")
+    (license (package-license perl))))
+
 (define-public perl-yaml
   (package
     (name "perl-yaml")