diff mbox series

[bug#57460,17/20] refresh: Allow updating to a specific version (documentation)

Message ID 8e4201238e61596c397823bfac5f46d09498ccc8.1661691694.git.h.goebel@crazy-compilers.com
State New
Headers show
Series Refresh to specific version | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Aug. 28, 2022, 1:18 p.m. UTC
---
 doc/guix.texi | 13 +++++++++++++
 1 file changed, 13 insertions(+)
diff mbox series

Patch

diff --git a/doc/guix.texi b/doc/guix.texi
index 7bce8a567c..c459fa6d4d 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -13747,6 +13747,19 @@  gnu/packages/multiprecision.scm:40:12: 6.1.2 is already the latest version of gm
 
 @end table
 
+If for some reason you don't want to update to the latest version,
+you can update to a specific version by passing a package specification.
+However, not all updaters support this.
+
+@example
+$ guix refresh trytond-party
+gnu/packages/tryton.scm:2101:13: trytond-party would be upgraded from 6.2.0 to 6.4.0
+$ guix refresh -u trytond-party@@6.2.1
+@dots{}
+gnu/packages/tryton.scm:2101:13: trytond-party: updating from version 6.2.0 to version 6.2.1...
+@dots{}
+@end example
+
 Sometimes the upstream name differs from the package name used in Guix,
 and @command{guix refresh} needs a little help.  Most updaters honor the
 @code{upstream-name} property in package definitions, which can be used