diff mbox series

[bug#57460,20/20] TEMP REMOVE Add test-script for refesh-with-version

Message ID 62dad0b7bef5982202eb8c512e15271355e0db86.1661691695.git.h.goebel@crazy-compilers.com
State New
Headers show
Series Refresh to specific version | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Aug. 28, 2022, 1:18 p.m. UTC
This commit will be dropped and not be committed to the main branch!
---
 test-import-with-version.sh | 98 +++++++++++++++++++++++++++++++++++++
 1 file changed, 98 insertions(+)
 create mode 100644 test-import-with-version.sh
diff mbox series

Patch

diff --git a/test-import-with-version.sh b/test-import-with-version.sh
new file mode 100644
index 0000000000..3aa09dda68
--- /dev/null
+++ b/test-import-with-version.sh
@@ -0,0 +1,98 @@ 
+echo -n "Number of importers: "
+ls guix/import/*.scm | wc -l
+
+echo -n "Number of updaters : "
+grep upstream-updater guix/import/*.scm | wc -l
+
+echo
+
+PKGS=()
+# chicken see below
+PKGS+=("crate rust-sequoia-openpgp@1.7.0")
+PKGS+=("generic-git remmina@1.4.25") # (import/git)
+PKGS+=("generic-html xclock@1.1.0")  # (gnu-maintenance)
+PKGS+=("github libwacom@1.12")       #
+PKGS+=("gnome gtranslator@41.0")
+PKGS+=("gnu help2man@1.49.1")        # (gnu-maintenance)
+PKGS+=("gnu-ftp libgpg-error@1.43")  # (gnu-maintenance)
+# hexpm see below
+PKGS+=("kde plasma-framework@5.96.0")
+PKGS+=("kernel.org iw@5.3")          # (gnu-maintenance) = html
+PKGS+=("launchpad soundconverter@4.0.0")  # will fail due to changed archive filename
+PKGS+=("pypi trytond-party@6.4.0")
+PKGS+=("savannah libpipeline@1.5.4") # (gnu-maintenance) = html
+PKGS+=("xorg libxi@1.7.99.2")        # (gnu-maintenance) = ftp
+
+
+for pkg in "${PKGS[@]}" ; do
+    echo "------------------------------------------" $pkg
+    pkg=${pkg//* }
+    nv=${pkg%@*}
+    ./pre-inst-env guix refresh $nv
+    ./pre-inst-env guix refresh -u $pkg
+    make make-go 2> /dev/null  # avoid "source file newer" messages
+done
+
+echo
+echo
+echo
+echo "=============================================="
+echo 'For these packages there is no newer version between the current one in guix'
+echo 'and the later one available upstream. Thus we need to "downgrade" the'
+echo 'version first. And to show that I specific version will be fetched, we'
+echo '"refresh" to an older version.'
+echo "---------------------------------------------"
+echo
+
+PKGS=()
+PKGS+=("egg chicken-srfi-13@0.3")
+PKGS+=("hexpm erlang-relx@4.5.0")
+# HACK
+sed -i -e s/"0\.3\.2"/"0.0.0"/ gnu/packages/chicken.scm
+sed -i -e s/"4\.6\.0"/"0.0.0"/ gnu/packages/erlang.scm
+make make-go 2> /dev/null  # avoid "source file newer" messages
+
+for pkg in "${PKGS[@]}" ; do
+    echo "---------------------------------------------" $pkg
+    pkg=${pkg//* }
+    nv=${pkg%@*}
+    ./pre-inst-env guix refresh -u $pkg
+    ./pre-inst-env guix refresh $nv
+    make make-go 2> /dev/null  # avoid "source file newer" messages
+done
+
+function try_fail () {
+    pkg=$1 ; shift
+    repo=$1 ; shift
+    echo "---------------------------------------------" $repo $pkg
+    echo -- "  shall fail since" $repo $1
+    ./pre-inst-env guix refresh -u $pkg
+    echo
+}
+
+echo
+echo
+echo "=============================================="
+echo 'These updates issue an error when trying to update to a specific version:'
+try_fail r-tximeta@1.5.4  'bioconductor (cran.scm)' 'repo supports latest version only'
+try_fail r-sungeo@0.2.290             'cran'        'repo supports latest version only'
+try_fail perl-socket-msghdr@0.10      'cpan'     'importer does not support version'
+try_fail emacs-vertico-posframe@0.5.9 'elpa'     'importer does not support version'
+try_fail ruby-commander@4.5.0         'gem'      'importer does not support version'
+try_fail ghc-singleton-bool@0.2.3     'hackage'  'importer does not support version'
+try_fail minetest-advtrains@2.5.0     'minetest' 'importer does not support version'
+try_fail ocaml-cudf@0.11              'opam'     'importer does not support version'
+try_fail xplanet@1.4.0 'sourceforge (gnu-maintenance)' 'to complicated to implement'
+
+echo
+echo
+echo "=============================================="
+echo 'These importers do not have an updater:'
+echo -- ' - json  -- n/a'
+echo -- ' - elm  -- has no updater and "elm-package-origin" sources are hosted at github'
+# try_fail elm-http@2.0.0 elm 'has no updater'
+try_fail texlive-sourcecodepro@60101 'texlive' 'has no updater'
+echo
+echo "=============================================="
+echo 'For these importers the  updater is not yet implemented:'
+echo -- ' - stackage  ---  unclear how to handle LTS version'