diff mbox series

[bug#64629] gnu: python-pyusb: Update to 1.2.1.

Message ID 89ccedb34b5d1cd4a286e465280f7d69423f5ec1.1689363756.git.simon@simonsouth.net
State New
Headers show
Series [bug#64629] gnu: python-pyusb: Update to 1.2.1. | expand

Commit Message

Simon South July 14, 2023, 7:45 p.m. UTC
* gnu/packages/libusb.scm (python-pyusb): Update to 1.2.1.
[native-inputs]: Add python-setuptools-scm.
---
Tested on AArch64 and x86-64 and all appears well.  All dependencies build
without issue since commit 917a299831.

 gnu/packages/libusb.scm | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)


base-commit: 917a299831361f253ea664f009176b4bbe06900a

Comments

宋文武 July 20, 2023, 11:22 a.m. UTC | #1
Simon South <simon@simonsouth.net> writes:

> * gnu/packages/libusb.scm (python-pyusb): Update to 1.2.1.
> [native-inputs]: Add python-setuptools-scm.
> ---
> Tested on AArch64 and x86-64 and all appears well.  All dependencies build
> without issue since commit 917a299831.

QA status is unknown (seems unreleated to me), but I got dependent
packages (stcgal python-capablerobot-usbhub rfcat yubikey-oath-dmenu)
built too.  So I applied it now, thank you!
diff mbox series

Patch

diff --git a/gnu/packages/libusb.scm b/gnu/packages/libusb.scm
index d0837c8a91..13090d30ab 100644
--- a/gnu/packages/libusb.scm
+++ b/gnu/packages/libusb.scm
@@ -274,14 +274,14 @@  (define-public python-libusb1
 (define-public python-pyusb
   (package
     (name "python-pyusb")
-    (version "1.0.2")
+    (version "1.2.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pyusb" version))
        (sha256
         (base32
-         "0qkk2jn270jwwl1x26hmdhb14m9kkbrzzwzizdjcl1a29b6756sf"))))
+         "1fg7knfzybzija2b01pzrzhzsj989scl12sb2ra4f503l8279k54"))))
     (build-system python-build-system)
     (arguments
      `(#:tests? #f                      ; no tests
@@ -302,6 +302,9 @@  (define-public python-pyusb
                                    "^libusb-.*\\.so\\..*"))
                  "\"")))
              #t)))))
+
+    (native-inputs
+     (list python-setuptools-scm))
     (inputs
      (list libusb))
     (home-page "https://pyusb.github.io/pyusb/")