diff mbox series

[bug#67905] gnu: Add emacs-golden-ratio.

Message ID 88b10c5b72478385da5d57218139845e93f48da0.1702995554.git.peter@polidoro.io
State New
Headers show
Series [bug#67905] gnu: Add emacs-golden-ratio. | expand

Commit Message

Peter Polidoro Dec. 19, 2023, 2:19 p.m. UTC
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/emacs-xyz.scm (emacs-golden-ratio): New variable.

Change-Id: I34fe0c67e8776083a9ae448d834eed8f4105d176
---
 gnu/packages/emacs-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)


base-commit: ee93015b54a2abfe59bc2270c09ea4f7624488e5

Comments

Mathieu Othacehe Dec. 25, 2023, 4:40 p.m. UTC | #1
Hello,

There are two linter warnings here:

--8<---------------cut here---------------start------------->8---
/home/mathieu/guix/gnu/packages/emacs-xyz.scm:1382:5:
emacs-golden-ratio@20230912.1825: the source file name should contain
the package name

/home/mathieu/guix/gnu/packages/emacs-xyz.scm:1382:5:
emacs-golden-ratio@20230912.1825: permanent redirect from
https://github.com/roman/golden-ratio.el.git to
https://github.com/roman/golden-ratio.el
--8<---------------cut here---------------end--------------->8---

> +       (uri (git-reference
> +             (url "https://github.com/roman/golden-ratio.el.git")
> +             (commit "375c9f287dfad68829582c1e0a67d0c18119dab9")))

The first one can probably be resolved by adding the following line
here:

         (file-name (git-file-name name version))

> +       (sha256
> +        (base32 "0a635a3h6jx0clgwmhwc48i14y3xy5q29y37lp2sjnbxx1hlmkli"))))
> +    (build-system emacs-build-system)
> +    (home-page "https://github.com/roman/golden-ratio.el")

And the second one by updating this URL.

Could you please send an updated patch?

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f8bd9a111e..e452e88283 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1374,6 +1374,27 @@  (define-public emacs-project-mode-line-tag
 its mode line.")
       (license license:gpl3+))))
 
+(define-public emacs-golden-ratio
+  (package
+    (name "emacs-golden-ratio")
+    (version "20230912.1825")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/roman/golden-ratio.el.git")
+             (commit "375c9f287dfad68829582c1e0a67d0c18119dab9")))
+       (sha256
+        (base32 "0a635a3h6jx0clgwmhwc48i14y3xy5q29y37lp2sjnbxx1hlmkli"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/roman/golden-ratio.el")
+    (synopsis "Automatic resizing of Emacs windows to the golden ratio")
+    (description "This package provides an Emacs mode for automatically
+resizing the window that has main focus to be more convenient for editing,
+while the ones that are not being actively edited will be reduced to a smaller
+size.")
+    (license license:expat)))
+
 (define-public emacs-git-modes
   (package
     (name "emacs-git-modes")