diff mbox series

[bug#66129,13/20] gnu: Add suitesparse-cxsparse.

Message ID 88ac0a8ff23aef774b68ebf1c43d55dafd651be8.1695246169.git.david.elsing@posteo.net
State New
Headers show
Series Split SuiteSparse into subpackages | expand

Commit Message

David Elsing Sept. 20, 2023, 10:08 p.m. UTC
* gnu/packages/maths.scm (suitesparse-cxsparse): New variable.
---
 gnu/packages/maths.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 1dfd12af76..57e3f82fa8 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5361,6 +5361,37 @@  (define-public suitesparse-cholmod
 and other related operations.")
     (license (list license:gpl2+ license:lgpl2.1+))))
 
+(define-public suitesparse-cxsparse
+  (package
+    (name "suitesparse-cxsparse")
+    (version "4.2.0")
+    (source (suitesparse-package-src name "CXSparse"))
+    (build-system cmake-build-system)
+    (arguments
+     (list
+      #:tests? #f
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'set-cmake-module-path
+            (lambda _
+              (substitute* "CMakeLists.txt"
+                (("set.*CMAKE_MODULE_PATH.*")
+                 (string-append "set(CMAKE_MODULE_PATH "
+                                #$suitesparse-config "/lib/cmake/SuiteSparse)\n"
+                                "set(DUMMY\n")))))
+          (replace 'install-license-files
+            (lambda _
+              (let ((out (string-append #$output
+                                        "/share/doc/" #$name "-" #$version)))
+                (install-file "../source/Doc/License.txt" out)
+                (install-file "../source/Doc/lesser.txt" out)))))))
+    (inputs (list suitesparse-config))
+    (home-page "https://people.engr.tamu.edu/davis/suitesparse.html")
+    (synopsis "Concise eXtended Sparse Matrix Package")
+    (description "CXSparse is a collection of sparse matrix algorithms for
+direct methods on both real and complex matrices.")
+    (license license:lgpl2.1+)))
+
 (define-public suitesparse
   (package
     (name "suitesparse")