diff mbox series

[bug#66129,10/20] gnu: Add gklib-suitesparse.

Message ID 28bb0d1f9a1530497514d57a15aabeb1990536a8.1695246169.git.david.elsing@posteo.net
State New
Headers show
Series Split SuiteSparse into subpackages | expand

Commit Message

David Elsing Sept. 20, 2023, 10:08 p.m. UTC
* gnu/packages/maths.scm (gklib-suitesparse): New variable.
---
 gnu/packages/maths.scm                       | 25 ++++++++
 gnu/packages/patches/gklib-suitesparse.patch | 65 ++++++++++++++++++++
 2 files changed, 90 insertions(+)
 create mode 100644 gnu/packages/patches/gklib-suitesparse.patch
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 3150bac47f..668d564edc 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5228,6 +5228,31 @@  (define-public suitesparse-ccolamd
 COLAMD which has the the option to apply constraints to the ordering.")
     (license license:bsd-3)))
 
+(define-public gklib-suitesparse
+  (package/inherit gklib
+    (name "gklib-suitesparse")
+    (source (origin
+              (inherit (package-source gklib))
+              (patches (cons
+                        (search-patch
+                         "gklib-suitesparse.patch")
+                        (origin-patches (package-source gklib))))))
+    (arguments
+     (substitute-keyword-arguments (package-arguments gklib)
+       ((#:phases phases #~%standard-phases)
+        #~(modify-phases #$phases
+            (add-after 'unpack 'patch-cmake
+              (lambda _
+                (substitute* "CMakeLists.txt"
+                  (("add_library\\(GKlib.*" all)
+                   (string-append
+                    all
+                    "target_link_libraries(GKlib PUBLIC"
+                    " ${SUITESPARSE_CONFIG_LIBRARIES} m)\n")))))))))
+    (inputs
+     (modify-inputs (package-inputs gklib)
+       (prepend suitesparse-config)))))
+
 (define-public suitesparse
   (package
     (name "suitesparse")
diff --git a/gnu/packages/patches/gklib-suitesparse.patch b/gnu/packages/patches/gklib-suitesparse.patch
new file mode 100644
index 0000000000..8b6c708b6a
--- /dev/null
+++ b/gnu/packages/patches/gklib-suitesparse.patch
@@ -0,0 +1,65 @@ 
+This patch contains the relevant changes to GKlib made in SuiteSparse
+(CHOLMOD) for the version 7.2.0
+(https://github.com/DrTimothyAldenDavis/SuiteSparse/commit/8a7641cdb4809533c681417e94f98058c07c5da2).
+The disabling of signal handling when MATLAB_MEX_FILE is defined is omitted.
+
+diff -ur a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -3,6 +3,8 @@
+ 
+ option(BUILD_SHARED_LIBS "Build shared libraries (.dll/.so) instead of static ones (.lib/.a)" OFF)
+ 
++find_package ( SuiteSparse_config 7.1.0 REQUIRED )
++
+ get_filename_component(abs "." ABSOLUTE)
+ set(GKLIB_PATH ${abs})
+ unset(abs)
+diff -ur a/GKlib.h b/GKlib.h
+--- a/GKlib.h
++++ b/GKlib.h
+@@ -59,6 +59,24 @@
+ #include <omp.h>
+ #endif
+ 
++/* -------------------------------------------------------------------------- */
++/* Added for incorporation into SuiteSparse.
++   Tim Davis, Oct 31, 2022, Texas A&M University. */
++#include "SuiteSparse_config.h"
++#define malloc  SuiteSparse_config_malloc
++#define calloc  SuiteSparse_config_calloc
++#define realloc SuiteSparse_config_realloc
++#define free(p)                                 \
++{                                               \
++    if ((p) != NULL)                            \
++    {                                           \
++        SuiteSparse_config_free (p) ;           \
++        (p) = NULL ;                            \
++    }                                           \
++}
++
++/* -------------------------------------------------------------------------- */
++
+ 
+ 
+ 
+diff -ur a/memory.c b/memory.c
+--- a/memory.c
++++ b/memory.c
+@@ -108,6 +108,8 @@
+ /*************************************************************************/
+ int gk_malloc_init()
+ {
++  gkmcore = NULL;
++#if 0
+   if (gkmcore == NULL)
+     gkmcore = gk_gkmcoreCreate();
+ 
+@@ -115,6 +117,7 @@
+     return 0;
+ 
+   gk_gkmcorePush(gkmcore);
++#endif
+ 
+   return 1;
+ }