diff mbox series

[bug#34692] gnu: add r-statcheck.

Message ID 87zhfzkzj6.fsf@guixSD.i-did-not-set--mail-host-address--so-tickle-me
State Accepted
Headers show
Series [bug#34692] gnu: add r-statcheck. | expand

Commit Message

Nicolò Balzarotti Dec. 11, 2019, 9 a.m. UTC
Nicolò Balzarotti <anothersms@gmail.com> writes:

> Hi, sorry for the delay!
> I'll try to have a look tomorrow :)
>
> Nicolò
>
> Il giorno sabato 23 marzo 2019, Ludovic Courtès <ludo@gnu.org> ha scritto:
>> Hi Nicolò,
>>
>> Ricardo Wurmus <rekado@elephly.net> skribis:
>>
>>> Unfortunately, this patch includes unrelated changes (to
>>> r-statnet-common) and does not have a proper commit summary.  The
>>> changes adding r-statcheck lack a proper description (you should use
>>> full sentences).
>>>
>>> Would you like to send another patch addressing these issues?
>>
>> Did you have a chance to look into that, Nicolò?
>>
>> Thanks in advance!
>>
>> Ludo’.
>>

I have to admit, today is not March 24th, but finally here's the updated
patch (no new versions have been released since btw).

Sorry for the delay and thanks!
Nicolò

Comments

Ricardo Wurmus Dec. 11, 2019, 10:15 a.m. UTC | #1
Nicolò Balzarotti <anothersms@gmail.com> writes:

> I have to admit, today is not March 24th, but finally here's the updated
> patch (no new versions have been released since btw).

Excellent, thank you!  I have applied it (after reflowing the
description with M-q).
diff mbox series

Patch

From 381ae9f063242b5740d5842b3fd515175a634a45 Mon Sep 17 00:00:00 2001
From: nixo <nicolo@nixo.xyz>
Date: Wed, 11 Dec 2019 09:51:30 +0100
Subject: [PATCH] gnu: Add r-statcheck.

* gnu/packages/cran.scm (r-statcheck): New variable.
---
 gnu/packages/cran.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 11d254001f..a8605221c3 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4168,6 +4168,31 @@  supports arbitrary vertex/edge/graph attributes.")
 software developed by the Statnet Project.")
     (license license:gpl3)))
 
+(define-public r-statcheck
+  (package
+    (name "r-statcheck")
+    (version "1.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "statcheck" version))
+       (sha256
+        (base32
+         "0ivybdcrymlsfv6pg6p5bv70qdvgxf2vgp0kf4r0pf2fcvav1mcp"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-ggplot2" ,r-ggplot2)
+       ("r-plyr" ,r-plyr)
+       ("r-rmarkdown" ,r-rmarkdown)))
+    (home-page
+     "https://cran.r-project.org/web/packages/statcheck")
+    (synopsis "Extract statistics from articles and recompute p-values")
+    (description "This package can automatically extract statistical null-hypothesis
+significant testing (NHST) results from articles and recompute the p-values
+based on the reported test statistic and degrees of freedom to detect possible
+inconsistencies.")
+    (license license:gpl2)))
+
 (define-public r-sna
   (package
     (name "r-sna")
-- 
2.24.0