diff mbox series

[bug#40128,2/2] gnu: Add emacs-major-mode-hydra.

Message ID 87zhccoq16.fsf@lafreniere.xyz
State Accepted
Headers show
Series [bug#40128,1/2] gnu: Add emacs-pretty-hydra. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

LaFreniere, Joseph March 19, 2020, 5:46 a.m. UTC
Patch file is attached.

--
Joseph LaFreniere

Comments

Nicolas Goaziou March 21, 2020, 4:41 p.m. UTC | #1
"LaFreniere, Joseph" <joseph@lafreniere.xyz> writes:

> +    (arguments
> +     `(#:phases
> +       (modify-phases %standard-phases
> +         (add-before 'add-source-to-load-path 'remove-pretty-hydra
> +           (lambda* (#:key outputs #:allow-other-keys)
> +             ;; pretty-hydra is provided by dependency.
> +             (delete-file "pretty-hydra.el")
> +             #t)))))

There, too, you may use #:exclude.
diff mbox series

Patch

From 387c56eaf4efe773065175b5db0dda0dc24c8dba Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Wed, 18 Mar 2020 20:59:09 -0500
Subject: [PATCH 2/2] gnu: Add emacs-major-mode-hydra.

* gnu/packages/emacs-xyz.scm (emacs-major-mode-hydra): New variable.

gnu: Add emacs-major-mode-hydra.

* gnu/packages/emacs-xyz.scm (emacs-major-mode-hydra): New variable.
---
 gnu/packages/emacs-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 54728d7165..74de919c80 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5610,6 +5610,26 @@  mode-specific key bindings.  It is intended for use as a library only; see
 package @code{emacs-major-mode-hydra} for a user-friendly interface.")
     (license license:gpl3+)))
 
+(define-public emacs-major-mode-hydra
+  (package
+    (inherit emacs-pretty-hydra)
+    (name "emacs-major-mode-hydra")
+    (propagated-inputs
+     `(("emacs-dash" ,emacs-dash)
+       ("emacs-pretty-hydra" ,emacs-pretty-hydra)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'add-source-to-load-path 'remove-pretty-hydra
+           (lambda* (#:key outputs #:allow-other-keys)
+             ;; pretty-hydra is provided by dependency.
+             (delete-file "pretty-hydra.el")
+             #t)))))
+    (synopsis "Create nice-looking hydras")
+    (description
+     "This package provides the macro @code{pretty-hydra-define} to define
+hydras with one column per group of heads.")))
+
 (define-public emacs-ivy
   (package
     (name "emacs-ivy")
-- 
2.25.1