diff mbox series

[bug#40128,1/2] gnu: Add emacs-pretty-hydra.

Message ID 871rpoq4tj.fsf@lafreniere.xyz
State Accepted
Headers show
Series [bug#40128,1/2] gnu: Add emacs-pretty-hydra. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

LaFreniere, Joseph March 19, 2020, 5:41 a.m. UTC
Patch file is attached.

As noted in the description, this package is not intended for use 
by end-users.  Is there a convention for communicating that?

--
Joseph LaFreniere

Comments

Nicolas Goaziou March 21, 2020, 4:38 p.m. UTC | #1
Hello,

"LaFreniere, Joseph" <joseph@lafreniere.xyz> writes:

> Patch file is attached.

Thank you.

> As noted in the description, this package is not intended for use by
> end-users.  Is there a convention for communicating that?

I think specifying it in the description is the correct way.

> +    (propagated-inputs
> +     `(("emacs-hydra" ,emacs-hydra)
> +       ("emacs-s" ,emacs-s)
> +       ("emacs-dash" ,emacs-dash)))

Could you re-order them alphabetically?

> +    (arguments
> +     `(#:phases
> +       (modify-phases %standard-phases
> +         (add-before 'add-source-to-load-path 'remove-pretty-hydra
> +           (lambda* (#:key outputs #:allow-other-keys)
> +             ;; major-mode-hydra is packaged separately.
> +             (delete-file "major-mode-hydra.el")
> +             #t)))))

You can use #:exclude keyword from the Emacs build system instead.

Could you send an updated patch?

Regards,
diff mbox series

Patch

From 77d0cc7e5fbda5dc0aa36cc16f8ffac6ca8591ad Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Wed, 18 Mar 2020 20:59:49 -0500
Subject: [PATCH 1/2] gnu: Add emacs-pretty-hydra.

* gnu/packages/emacs-xyz.scm (emacs-pretty-hydra): New variable.
---
 gnu/packages/emacs-xyz.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a821bc7776..54728d7165 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5576,6 +5576,40 @@  the Hydra very seamless; it's like a minor mode that disables itself
 automatically.")
     (license license:gpl3+)))
 
+(define-public emacs-pretty-hydra
+  (package
+    (name "emacs-pretty-hydra")
+    (version "0.2.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/jerrypnz/major-mode-hydra.el.git")
+             (commit version)))
+       (sha256
+        (base32
+         "08a15knkdq35pzjq82imff016fbfdib5q4glg2xmdy2b5fnk7jqa"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-hydra" ,emacs-hydra)
+       ("emacs-s" ,emacs-s)
+       ("emacs-dash" ,emacs-dash)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'add-source-to-load-path 'remove-pretty-hydra
+           (lambda* (#:key outputs #:allow-other-keys)
+             ;; major-mode-hydra is packaged separately.
+             (delete-file "major-mode-hydra.el")
+             #t)))))
+    (home-page "https://github.com/jerrypnz/major-mode-hydra.el")
+    (synopsis "Major mode keybindings managed by Hydra")
+    (description
+     "This package offers an hydra-based method of managing major
+mode-specific key bindings.  It is intended for use as a library only; see
+package @code{emacs-major-mode-hydra} for a user-friendly interface.")
+    (license license:gpl3+)))
+
 (define-public emacs-ivy
   (package
     (name "emacs-ivy")
-- 
2.25.1