diff mbox series

[bug#45972] Add julia-json with dependencies

Message ID 87y2gdax8j.fsf@guixSD.i-did-not-set--mail-host-address--so-tickle-me
State Accepted
Headers show
Series [bug#45972] Add julia-json with dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Nicolò Balzarotti Jan. 28, 2021, 3:37 p.m. UTC
Ludovic Courtès <ludo@gnu.org> writes:

> Buon giorno!
>
>>> IMO, that shouldn’t be the case.
> If it was me it was probably an oversight, I’m sorry about that.

No problem! It appeared also in the manual so I fixed it

>
>>> Can we either extract the Julia package name from metadata that’s in
>>> the package itself (?), or otherwise pass it to all the phases via
>>> ‘julia-build-system’?
>
> Sounds reasonable to me.  If I understand the toml format correctly,
> “name=.*” is guaranteed to be on a line on its own, so that looks
> safe.

exactly

>
> To be on the safe side, we can add a #:julia-package-name parameter to
> the build system; it would default to #f, in which case the name is
> extracted from the toml file.
>
Done, I attached the updated patch set!

Comments

Ludovic Courtès Jan. 30, 2021, 2:10 p.m. UTC | #1
Hi,

Nicolò Balzarotti <anothersms@gmail.com> skribis:

> Done, I attached the updated patch set!

Applied it all, thanks a lot!

Ludo’.
diff mbox series

Patch

From 3da3028123253ebe69017607e3dc7c8825b47c51 Mon Sep 17 00:00:00 2001
From: nixo <nicolo@nixo.xyz>
Date: Tue, 19 Jan 2021 00:06:34 +0100
Subject: [PATCH v4 11/11] gnu: Add julia-json.

* gnu/packages/julia-xyz.scm (julia-json): New variable.
---
 gnu/packages/julia-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 3dd731ef28..34dba958ce 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -125,6 +125,31 @@  scaled by a constant factor.  Consequently, they have a fixed number of
 digits (bits) after the decimal (radix) point.")
     (license license:expat)))
 
+(define-public julia-json
+  (package
+    (name "julia-json")
+    (version "0.21.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/JuliaIO/JSON.jl")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1f9k613kbknmp4fgjxvjaw4d5sfbx8a5hmcszmp1w9rqfqngjx9m"))))
+    (build-system julia-build-system)
+    (propagated-inputs
+     `(("julia-datastructures" ,julia-datastructures)
+       ("julia-fixedpointnumbers" ,julia-fixedpointnumbers)
+       ("julia-parsers" ,julia-parsers)
+       ("julia-offsetarrays" ,julia-offsetarrays)))
+    (home-page "https://github.com/JuliaIO/JSON.jl")
+    (synopsis "JSON parsing and printing library for Julia")
+    (description "@code{JSON.jl} is a pure Julia module which supports parsing
+and printing JSON documents.")
+    (license license:expat)))
+
 (define-public julia-orderedcollections
   (package
     (name "julia-orderedcollections")
-- 
2.30.0