diff mbox series

[bug#47037] gnu: emacs-password-store: 2.1.4-1.918992c [security fix].

Message ID 87y2ev5pin.fsf@gmx.com
State Accepted
Headers show
Series [bug#47037] gnu: emacs-password-store: 2.1.4-1.918992c [security fix]. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Pierre Langlois March 10, 2021, 9:25 a.m. UTC
Hi guix!

I noticed the update to the password-store yesterday and so got curious
what changes we had and took a look at the git repository. I was really
happy to find the emacs package includes a fix [0] for a bug I've been
experiencing for a long time, where using pass inside EXWM would
deadlock emacs.

Taking a closer look as well, the commit also fixes a potentially quite
critical security issue with the package, I think we better apply it :-/.

Is this OK to commit? I've tested this locally on EXWM via ivy-pass.

Thanks,
Pierre

[0]: https://git.zx2c4.com/password-store/commit/contrib?id=7aa17d099577730d2d65332896b74d5865b22abf

Comments

Pierre Langlois March 11, 2021, 10:04 a.m. UTC | #1
Hi Guix!

Pierre Langlois writes:

> Hi guix!
>
> I noticed the update to the password-store yesterday and so got curious
> what changes we had and took a look at the git repository. I was really
> happy to find the emacs package includes a fix [0] for a bug I've been
> experiencing for a long time, where using pass inside EXWM would
> deadlock emacs.
>
> Taking a closer look as well, the commit also fixes a potentially quite
> critical security issue with the package, I think we better apply it :-/.
>
> Is this OK to commit? I've tested this locally on EXWM via ivy-pass.

I figured this patch is just a straight-forward update, and quite an
important one, so I've just gone ahead and pushed it, adding an extra
comment that the emacs package version doesn't match the password-store
program version.

I figured maintainer's time are better spend not reviewing trivial
patches too much unless it's for onboarding newcomers :-).

Please shout if there are any issues!

Thanks,
Pierre
diff mbox series

Patch

From c49967bd6946887e2314a0817c717391f71794ed Mon Sep 17 00:00:00 2001
From: Pierre Langlois <pierre.langlois@gmx.com>
Date: Wed, 10 Mar 2021 09:12:02 +0000
Subject: [PATCH] gnu: emacs-password-store: 2.1.4-1.918992c [security fix].

Includes a fix to no longer store clear passwords in a temporary file, see
commit 7aa17d099577730d2d65332896b74d5865b22abf for details.

* gnu/packages/emacs-xyz.scm (emacs-password-store): Update to
2.1.4-1.918992c.
[propagated-inputs]: Remove emacs-f, add emacs-auth-source-pass.
---
 gnu/packages/emacs-xyz.scm | 67 ++++++++++++++++++++------------------
 1 file changed, 35 insertions(+), 32 deletions(-)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b5785505a5..59e968c508 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15041,39 +15041,42 @@  close, copy, cut, paste, undo, redo.")
       (license license:gpl3+))))

 (define-public emacs-password-store
-  (package
-    (name "emacs-password-store")
-    (version "1.7.3")
-    (source (origin
-              (method url-fetch)
-              (uri
-               (string-append "https://git.zx2c4.com/password-store/snapshot/"
-                              "password-store-" version ".tar.xz"))
-              (sha256
-               (base32
-                "1x53k5dn3cdmvy8m4fqdld4hji5n676ksl0ql4armkmsds26av1b"))))
-    (build-system emacs-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'extract-el-file
-           (lambda _
-             (copy-file "contrib/emacs/password-store.el" "password-store.el")
-             (delete-file-recursively "contrib")
-             (delete-file-recursively "man")
-             (delete-file-recursively "src")
-             (delete-file-recursively "tests"))))))
-    (propagated-inputs
-     `(("emacs-f" ,emacs-f)
-       ("emacs-s" ,emacs-s)
-       ("emacs-with-editor" ,emacs-with-editor)
-       ("password-store" ,password-store)))
-    (home-page "https://git.zx2c4.com/password-store/tree/contrib/emacs")
-    (synopsis "Password store (pass) support for Emacs")
-    (description
-     "This package provides functions for working with pass (\"the
+  (let ((commit "918992c19231b33b3d4a3288a7288a620e608cb4")
+        (revision "1"))
+    (package
+      (name "emacs-password-store")
+      (version (git-version "2.1.4" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "git://git.zx2c4.com/password-store")
+                      (commit commit)))
+                (sha256
+                 (base32
+                  "0ni62f4pq96g0i0q66bch1dl9k4zqwhg7xaf746k3gbbqxcdh3vi"))
+                (file-name (git-file-name name version))))
+      (build-system emacs-build-system)
+      (arguments
+       `(#:phases
+         (modify-phases %standard-phases
+           (add-after 'unpack 'extract-el-file
+             (lambda _
+               (copy-file "contrib/emacs/password-store.el" "password-store.el")
+               (delete-file-recursively "contrib")
+               (delete-file-recursively "man")
+               (delete-file-recursively "src")
+               (delete-file-recursively "tests"))))))
+      (propagated-inputs
+       `(("emacs-auth-source-pass" ,emacs-auth-source-pass)
+         ("emacs-s" ,emacs-s)
+         ("emacs-with-editor" ,emacs-with-editor)
+         ("password-store" ,password-store)))
+      (home-page "https://git.zx2c4.com/password-store/tree/contrib/emacs")
+      (synopsis "Password store (pass) support for Emacs")
+      (description
+       "This package provides functions for working with pass (\"the
 standard Unix password manager\").")
-    (license license:gpl2+)))
+      (license license:gpl2+))))

 (define-public emacs-auth-source-pass
   (let ((commit "847a1f54ed48856b4dfaaa184583ef2c84173edf")
--
2.30.1