diff mbox

[bug#38546,00/11] Update Julia, Fix precompilation, add HTTP.jl

Message ID 87wo9ouaq5.fsf@guixSD.i-did-not-set--mail-host-address--so-tickle-me
State Accepted
Headers show

Commit Message

Nicolò Balzarotti Jan. 18, 2020, 1:59 p.m. UTC
I'm sending the patches again as attachments since I think some of them
was badly formatted.

Comments

Simon Tournier Jan. 20, 2020, 6:49 p.m. UTC | #1
Hi Nicolò,

Thank you for working on this.
Julia rocks! ;-)


However, I am lost with your patch set.

I have tried only the first patch you attached. I hit this error:

--8<---------------cut here---------------start------------->8---
error: dsfmt: unbound variable
--8<---------------cut here---------------end--------------->8---

So something is missing. :-)

Then I notice that you change the list of 'patches' and you "forgot"
to send them too. :-)


Almost related, does this update fix the reproducibility bug [1]? For example,

--8<---------------cut here---------------start------------->8---
./pre-inst-env guix build julia
./pre-inst-env guix build julia --check --no-grafts -K
--8<---------------cut here---------------end--------------->8---


[1] https://debbugs.gnu.org/cgi/bugreport.cgi?bug=22304


All the best,
simon
diff mbox

Patch

From bd7ba60316819b1201966dc650f50e4c320a4dfd Mon Sep 17 00:00:00 2001
From: nixo <nicolo@nixo.xyz>
Date: Sat, 18 Jan 2020 14:11:45 +0100
Subject: [PATCH 11/11] gnu: Add julia-http.

* gnu/packages/julia-xyz.scm (julia-http): New variable.
---
 gnu/packages/julia-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 3e9f532697..ff1bb483f9 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -148,3 +148,27 @@  binaries required by julia packages.")
     (description "@code{MbedTLS.jl} provides a wrapper around the mbed TLS and
 cryptography C libary for Julia.")
     (license license:expat)))
+
+(define-public julia-http
+  (package
+    (name "julia-http")
+    (version "0.8.8")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/JuliaWeb/HTTP.jl")
+             (commit (string-append "v" version))))
+       (file-name "HTTP")
+       (sha256
+        (base32 "0928fvncfp07i5hvqxjyj8i27xmxxllas1m5idqq2i8h7jshzq3y"))))
+    (propagated-inputs
+     `(("julia-inifile" ,julia-inifile)
+       ("julia-mbedtls" ,julia-mbedtls)
+       ("julia-compat" ,julia-compat)))
+    (build-system julia-build-system)
+    (home-page "https://juliaweb.github.io/HTTP.jl/")
+    (synopsis "HTTP support for Julia")
+    (description "@code{HTTP.jl} is a Julia library for HTTP Messages,
+implementing both a client and a server.")
+    (license license:expat)))
-- 
2.24.1