diff mbox series

[bug#50372] Add qolibri with its dependency

Message ID 87wnnwijx4.fsf@guix.i-did-not-set--mail-host-address--so-tickle-me
State Accepted
Headers show
Series [bug#50372] Add qolibri with its dependency | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Nicolò Balzarotti Sept. 4, 2021, 12:50 p.m. UTC
Hi guix!

Those two patches add qolibri, a dictionary viewver for the EPWING
format (used by Japanese dictionaries) and libeb, a library used by
qolibri to read those dictionaries.


I could not find an homepage for libeb: AUR and NixOS do not have a
working one (404 and missing), so I added the website where the file can
be downloaded (but the website is in Japanese, if the libeb page was
just moved I could not find it).

Both packages build and guix lint does not complain.

I was not sure about the best place for libeb (maybe it fits better
under cdrom.scm)

Thanks!
Nicolò

Comments

Nicolas Goaziou Sept. 13, 2021, 8:43 p.m. UTC | #1
Hello,

Nicolò Balzarotti <anothersms@gmail.com> writes:
>
> Those two patches add qolibri, a dictionary viewver for the EPWING
> format (used by Japanese dictionaries) and libeb, a library used by
> qolibri to read those dictionaries.

Thanks! Applied!

> I was not sure about the best place for libeb (maybe it fits better
> under cdrom.scm)

I'm not sure either, but its current location will do for now.


Regards,
diff mbox series

Patch

From 6d8228deb30b4aedfaadf6cda76bbe346a184baa Mon Sep 17 00:00:00 2001
From: nixo <nicolo@nixo.xyz>
Date: Sat, 4 Sep 2021 14:26:17 +0200
Subject: [PATCH 2/2] gnu: Add qolibri.

* gnu/packages/education.scm (qolibri): New variable.
---
 gnu/packages/education.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 897dd37088..2039347ddc 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -1045,6 +1045,40 @@  formats.")
     (home-page "https://sra.co.jp/")
     (license license:bsd-3)))
 
+(define-public qolibri
+  (package
+    (name "qolibri")
+    (version "2.1.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url"https://github.com/ludios/qolibri")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "066y7jcq9vg6hnvn7qxckzhd1qkgfzpzhw69nw5psm43qbaca8lg"))))
+    (build-system qt-build-system)
+    (arguments
+     '(#:tests? #f)) ; no test target
+    (native-inputs
+     `(("qttools", qttools)))
+    (inputs
+     `(("libeb" ,libeb)
+       ("qtbase" ,qtbase-5)
+       ("qtmultimedia" ,qtmultimedia)
+       ("qtquickcontrols2" ,qtquickcontrols2)
+       ("qtdeclarative" ,qtdeclarative)
+       ("qtwebchannel" ,qtwebchannel)
+       ("qtwebengine" ,qtwebengine)
+       ("zlib" ,zlib)))
+    (synopsis "EPWING dictionary reader")
+    (description "qolibri is a dictionary viewer for the EPWING dictionary
+format.  Most monolingual Japanese dictionaries can only be found in the
+EPWING format.")
+    (home-page "https://github.com/ludios/qolibri")
+    (license license:gpl2)))
+
 (define-public mdk
   (package
     (name "mdk")
-- 
2.33.0