diff mbox series

[bug#44425,1/3] gnu: Add ghc-mountpoints.

Message ID 87v9em8551.fsf@dustycloud.org
State Accepted
Headers show
Series [bug#44425,1/3] gnu: Add ghc-mountpoints. | expand

Commit Message

Christine Lemmer-Webber Nov. 3, 2020, 10:08 p.m. UTC
Here we go... this actually works now.  Working git-annex assistant!

For whatever reason I also seemed to enable pairing to get this to
function (there was a compilation error otherwise).

Comments

Timothy Sample Nov. 4, 2020, 4:41 a.m. UTC | #1
Hi Christopher,

Christopher Lemmer Webber <cwebber@dustycloud.org> writes:

> Here we go... this actually works now.  Working git-annex assistant!

That was fast!

I have two little notes.  (1) Packages in “haskell-xyz.scm” are sorted
alphabetically, so the new packages shouldn’t go at the end (that file
is something of an outlier there).  (2) The license of
ghc-network-multicast is not really clear.  According to “LICENSE” and
“network-multicast.cabal”, it is CC0.  However, at the top of the only
source file, “src/Network/Multicast.hsc”, it has “License: MIT License”
as a comment.  I don’t think there’s a right answer for us, and I think
your choice of the Expat license is reasonable, but maybe it deserves a
comment?

Otherwise, it all lints, builds, runs fine, and LGTM!


-- Tim
Christine Lemmer-Webber Nov. 4, 2020, 4:03 p.m. UTC | #2
Timothy Sample writes:

> Hi Christopher,
>
> Christopher Lemmer Webber <cwebber@dustycloud.org> writes:
>
>> Here we go... this actually works now.  Working git-annex assistant!
>
> That was fast!
>
> I have two little notes.  (1) Packages in “haskell-xyz.scm” are sorted
> alphabetically, so the new packages shouldn’t go at the end (that file
> is something of an outlier there).

Okay, I'll fix that.

> (2) The license of ghc-network-multicast is not really clear.
> According to “LICENSE” and “network-multicast.cabal”, it is CC0.
> However, at the top of the only source file,
> “src/Network/Multicast.hsc”, it has “License: MIT License” as a
> comment.  I don’t think there’s a right answer for us, and I think
> your choice of the Expat license is reasonable, but maybe it deserves
> a comment?

Yes, I observed that also.  Both are listed.  Functionally I think that
makes it effectively Expat/MIT, though notably CC0 has a nontrivial
"fallback license" associated with it in the cases where public domain
is not recognized in a jurisdiction, so it's probably more both.  I'll
leave a comment, I think that'll be sufficient.

> Otherwise, it all lints, builds, runs fine, and LGTM!

Woo woo!  Will make the changes you suggested and then push.

> -- Tim
diff mbox series

Patch

From 1c11f5e8141691e3540cc451c3c4d213fdd38067 Mon Sep 17 00:00:00 2001
From: Christopher Lemmer Webber <cwebber@dustycloud.org>
Date: Tue, 3 Nov 2020 17:00:02 -0500
Subject: [PATCH 1/3] gnu: Add ghc-mountpoints.

* gnu/packages/haskell-xyz.scm (ghc-mountpoints): New variable.
---
 gnu/packages/haskell-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 43dc7d5bbf..f9da8f573a 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -27,6 +27,7 @@ 
 ;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@member.fsf.org>
 ;;; Copyright © 2020 Carlo Holl <carloholl@gmail.com>
+;;; Copyright © 2020 Christopher Lemmer Webber <cwebber@dustycloud.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -15416,3 +15417,25 @@  Zstandard compression algorithm, a fast lossless compression algorithm
 targeting real-time compression scenarios at zlib-level and better
 compression ratios.")
     (license license:bsd-3)))
+
+(define-public ghc-mountpoints
+  (package
+    (name "ghc-mountpoints")
+    (version "1.0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/mountpoints/mountpoints-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "1hnm31pqcffphyc463wf0vbik9fzm5lb2r4wjdc1y4dqzmjdzz37"))))
+    (build-system haskell-build-system)
+    (home-page
+     "http://hackage.haskell.org/package/mountpoints")
+    (synopsis "Haskell library for listing mount points")
+    (description "This library provides Haskell bindings for checking
+currently mounted filesystems.")
+    (license license:lgpl2.1+)))
-- 
2.29.1