diff mbox series

[bug#44425,2/3] gnu: Add ghc-network-multicast.

Message ID 87sg9q8542.fsf@dustycloud.org
State Accepted
Headers show
Series [bug#44425,1/3] gnu: Add ghc-mountpoints. | expand

Commit Message

Christine Lemmer-Webber Nov. 3, 2020, 10:09 p.m. UTC

diff mbox series

Patch

From 3b0f21df17b9265e6366da0611e7441e66015f0d Mon Sep 17 00:00:00 2001
From: Christopher Lemmer Webber <cwebber@dustycloud.org>
Date: Tue, 3 Nov 2020 17:02:50 -0500
Subject: [PATCH 2/3] gnu: Add ghc-network-multicast.

* gnu/packages/haskell-xyz.scm (ghc-network-multicast): New variable.
---
 gnu/packages/haskell-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index f9da8f573a..a10299d48e 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -15439,3 +15439,29 @@  compression ratios.")
     (description "This library provides Haskell bindings for checking
 currently mounted filesystems.")
     (license license:lgpl2.1+)))
+
+(define-public ghc-network-multicast
+  (package
+    (name "ghc-network-multicast")
+    (version "0.3.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/network-multicast/network-multicast-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "0whvi0pbwjy6dbwfdf9rv1j3yr3lcmfp3q7a8pwq63g537l4l2l3"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-network" ,ghc-network)
+       ("ghc-network-bsd" ,ghc-network-bsd)))
+    (home-page
+     "http://hackage.haskell.org/package/network-multicast")
+    (synopsis "Simple multicast library for Haskell")
+    (description
+     "This package provides the Network.Multicast Haskell module for
+sending UDP datagrams over multicast (class D) addresses.")
+    (license license:expat)))
-- 
2.29.1