diff mbox series

[bug#68156] gnu: python-hicexplorer: Fix build.

Message ID 87sf3jtqz2.fsf@troyfigiel.com
State New
Headers show
Series [bug#68156] gnu: python-hicexplorer: Fix build. | expand

Commit Message

Troy Figiel Dec. 30, 2023, 7:36 p.m. UTC
* gnu/packages/bioinformatics.scm (python-hicexplorer)[snippet]: Remove
catchall pattern of patch version numbers in setup.py.
---
 gnu/packages/bioinformatics.scm | 11 ++++++++++-
 1 file changed, 10 insertions(+), 1 deletion(-)


base-commit: f24b14767d362a84e6469682b4fe303b50f4b589

Comments

Mathieu Othacehe Jan. 4, 2024, 12:39 p.m. UTC | #1
> * gnu/packages/bioinformatics.scm (python-hicexplorer)[snippet]: Remove
> catchall pattern of patch version numbers in setup.py.

Applied, thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index de37d19264..0fa0961735 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -16602,7 +16602,16 @@  (define-public python-hicexplorer
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "1yavgxry38g326z10bclvdf8glmma05fxj5m73h15m1r2l9xmw3v"))))
+         "1yavgxry38g326z10bclvdf8glmma05fxj5m73h15m1r2l9xmw3v"))
+       (modules '((guix build utils)))
+       ;; setup.py is malformed. The requirements are defined using a catchall
+       ;; pattern for the patch version number. This has been fixed in version
+       ;; 3.7.3, but we cannot upgrade to this version yet, since some Guix
+       ;; packages are not new enough. (See upstream commit
+       ;; 4845c715ec7b105e938d0c2426e27d0181690bfe for the fix).
+       (snippet '(substitute* "setup.py"
+                   (("\\.\\*")
+                    "")))))
     (build-system pyproject-build-system)
     (arguments
      (list