From 9260aa91b6bc30b9abf0b6ead815d3a76f780a9b Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Thu, 26 May 2022 14:27:41 -0700
Subject: [PATCH 2/3] gnu: Add librecast.
* gnu/packages/networking.scm (librecast): New variable.
---
gnu/packages/networking.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)
@@ -419,6 +419,41 @@ (define-public libnice
license:lgpl2.1+
license:mpl1.1)))))
+(define-public librecast
+ (package
+ (name "librecast")
+ (version "0.5.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/librecast/librecast")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1zzdxawzsj0lxyxm8c2wdqx3b633f8ybvlg6szs4v0y42xg4a829"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:parallel-tests? #f
+ #:make-flags (let ((target ,(%current-target-system)))
+ (list ,(string-append "CC="
+ (cc-for-target))
+ (string-append "PREFIX="
+ (assoc-ref %outputs "out"))))
+ #:phases (modify-phases %standard-phases
+ (add-before 'check 'drop-test
+ (lambda _
+ (delete-file "./test/0000-0040.c")))
+ (replace 'check
+ (lambda _
+ (invoke "make" "test"))))))
+ (inputs (list libsodium lcrq))
+ (synopsis "librecast IPv6 multicast library")
+ (description "Librecast is a C library which supports IPv6 multicast
+networking.")
+ (home-page "https://librecast.net/librecast.html")
+ (license (list license:gpl2 license:gpl3))))
+
(define-public rtmpdump
;; There are no tags in the repository, and the project is unlikely to
;; make new releases. Take a recent commit for multiple security fixes
--
2.35.1