diff mbox series

[bug#55682,V2,1/3] gnu: Add lcrq.

Message ID 87tu6yyxr2.fsf@contorta
State Accepted
Headers show
Series [bug#55682,V2,1/3] gnu: Add lcrq. | expand

Commit Message

Vagrant Cascadian July 30, 2022, 11:41 p.m. UTC

Comments

M Aug. 11, 2022, 9:48 a.m. UTC | #1
On 31-07-2022 01:41, Vagrant Cascadian wrote:
> +                  (replace 'check
> +                    (lambda _
> +                      (invoke "make" "test"))))))

I expect "./pre-inst-env guix lint lcrq" to have a warning about 
respecting #:tests?. This is important for --without-tests and 
cross-compilation. Likewise for the other patches.

> +       #:make-flags (let ((target ,(%current-target-system)))
> +                      (list ,(string-append "CC="
> +                                            (cc-for-target))
> +                            (string-append "PREFIX="
> +                                           (assoc-ref %outputs "out"))))
'target' is unused and can be removed.

Greetings,
Maxime.
Vagrant Cascadian Aug. 12, 2022, 6:15 p.m. UTC | #2
On 2022-08-11, Maxime Devos wrote:
> On 31-07-2022 01:41, Vagrant Cascadian wrote:
>> +                  (replace 'check
>> +                    (lambda _
>> +                      (invoke "make" "test"))))))
>
> I expect "./pre-inst-env guix lint lcrq" to have a warning about 
> respecting #:tests?. This is important for --without-tests and 
> cross-compilation. Likewise for the other patches.

Oops. Looks like Efraim caught this after I pushed, at least.

>> +       #:make-flags (let ((target ,(%current-target-system)))
>> +                      (list ,(string-append "CC="
>> +                                            (cc-for-target))
>> +                            (string-append "PREFIX="
>> +                                           (assoc-ref %outputs "out"))))
> 'target' is unused and can be removed.

Nice catch, will look at it!


live well,
  vagrant
diff mbox series

Patch

From 4632adcfda6149945b7b02c2a3160ba38cf1cd03 Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Fri, 29 Jul 2022 15:01:49 -0700
Subject: [PATCH 1/3] gnu: Add lcrq.

* gnu/packages/networking.scm (lcrq): New variable.
---
 gnu/packages/networking.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index a48c4997ef..6c1adf43bc 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -239,6 +239,42 @@  (define-public axel
 protocols.")
     (license license:gpl2+)))
 
+(define-public lcrq
+  (package
+    (name "lcrq")
+    (version "0.0.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://codeberg.org/librecast/lcrq")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0jf7x3zcdbz5b99qz7liw4i90hn9s457zr82n0r8g9qsi81a1d8c"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:parallel-tests? #f
+       #:make-flags (let ((target ,(%current-target-system)))
+                      (list ,(string-append "CC="
+                                            (cc-for-target))
+                            (string-append "PREFIX="
+                                           (assoc-ref %outputs "out"))))
+       #:phases (modify-phases %standard-phases
+                  (replace 'check
+                    (lambda _
+                      (invoke "make" "test"))))))
+    (home-page "https://librecast.net/lcrq.html")
+    (synopsis "librecast RaptorQ library")
+    (description
+     "C library implementation of RaptorQ Forward Error Correction for
+Librecast.  RFC6330 (IETF) describes the RaptorQ proposed standard, which LCRQ
+more-or-less follows. The primary focus has been on building a fast, simple
+and dependency-free FEC implementation for use with Librecast, and not on
+strict standards compliance.  The code does, however, fairly closely follow
+the RFC.")
+    (license (list license:gpl2 license:gpl3))))
+
 ;; This package does not have a release yet.
 ;; But this is required to provide a feature in PipeWire.
 (define-public libcamera
-- 
2.35.1