[bug#70344] Increase verbosity of diffoscope test suite

Message ID 87r0fb3cgx.fsf@wireframe
State New
Headers
Series [bug#70344] Increase verbosity of diffoscope test suite |

Commit Message

Vagrant Cascadian April 11, 2024, 7:50 p.m. UTC
  The attached patch increases the verbosity of the test suite, showing
each test on it's own line and provides a useful summary, often
including a reason why skipped tests were skipped.

This can be useful to help find additional packages to add for broader
test coverage, inspired by discussion in
https://issues.guix.gnu.org/70293

This also reveals that the conditional to add "enjarify" to
native-inputs on x86_64 is not working correctly... and plausibly could
reveal other similar issues with other missing native-inputs.

live well,
  vagrant
  

Comments

Vagrant Cascadian May 18, 2024, 3:08 a.m. UTC | #1
On 2024-04-15, Christopher Baines wrote:
> Vagrant Cascadian <vagrant@reproducible-builds.org> writes:
>
>> The attached patch increases the verbosity of the test suite, showing
>> each test on it's own line and provides a useful summary, often
>> including a reason why skipped tests were skipped.
>>
>> This can be useful to help find additional packages to add for broader
>> test coverage, inspired by discussion in
>> https://issues.guix.gnu.org/70293
>>
>> This also reveals that the conditional to add "enjarify" to
>> native-inputs on x86_64 is not working correctly... and plausibly could
>> reveal other similar issues with other missing native-inputs.
>>
>> live well,
>>   vagrant
>>
>> [2. text/x-diff; 0001-gnu-diffoscope-Increase-test-verbosity.patch]
>> From b1475226dc655986e97445dca889d4b0c362215c Mon Sep 17 00:00:00 2001
>> From: Vagrant Cascadian <vagrant@reproducible-builds.org>
>> Date: Thu, 11 Apr 2024 12:40:19 -0700
>> Subject: [PATCH] gnu: diffoscope: Increase test verbosity.
>>
>> * gnu/packages/diffoscope.scm (diffoscope)[phases]: Replace 'check.
>> ---
>>  gnu/packages/diffoscope.scm | 5 +++++
>>  1 file changed, 5 insertions(+)
>
> This looks great, I've pushed it to master as
> 4dec6e9fb74a688e0297b127773b88a699531785.

Sending to the correct -done address. :)

live well,
  vagrant
  

Patch

From b1475226dc655986e97445dca889d4b0c362215c Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@reproducible-builds.org>
Date: Thu, 11 Apr 2024 12:40:19 -0700
Subject: [PATCH] gnu: diffoscope: Increase test verbosity.

* gnu/packages/diffoscope.scm (diffoscope)[phases]: Replace 'check.
---
 gnu/packages/diffoscope.scm | 5 +++++
 1 file changed, 5 insertions(+)

diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index 3db52e5008..8106a6d258 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -139,6 +139,11 @@  (define (bin command)
             (lambda _
               ;; This requires /sbin to be in $PATH.
               (delete-file "tests/test_tools.py")))
+         (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               ;; Increase verbosity of tests and provide a summary
+               (invoke "pytest" "-vv" "-r" "sxX"))))
           (add-after 'install 'install-man-page
             (lambda* (#:key outputs #:allow-other-keys)
               (let* ((out (assoc-ref outputs "out"))
-- 
2.39.2