diff mbox series

[bug#58078,1/2] gnu: emacs-pdf-tools: Fix build with native compilation.

Message ID 87o7v3to3x.fsf@protonmail.com
State Accepted
Headers show
Series Fix two emacs packages with native compilation. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

John Kehayias Sept. 25, 2022, 4:28 p.m. UTC
Empty Message
diff mbox series

Patch

From 1bbe765fb9972dbc9073e01ba66e30a8d806f962 Mon Sep 17 00:00:00 2001
From: John Kehayias <john.kehayias@protonmail.com>
Date: Sun, 25 Sep 2022 12:07:11 -0400
Subject: [PATCH 1/2] gnu: emacs-pdf-tools: Fix build with native compilation.

* gnu/packages/emacs-xyz.scm (emacs-pdf-tools)[phases]: Add the
add-install-to-native-load-path phase from emacs:%standard-phases after the
emacs-expand-load-path phase.
---
 gnu/packages/emacs-xyz.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e48757ee69..b6e64f812d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4047,7 +4047,9 @@  (define-public emacs-pdf-tools
                ("pdf-tools-handle-upgrades" '()))))
          (add-after 'emacs-patch-variables 'emacs-expand-load-path
            (assoc-ref emacs:%standard-phases 'expand-load-path))
-         (add-after 'emacs-expand-load-path 'emacs-install
+         (add-after 'emacs-expand-load-path 'emacs-add-install-to-native-load-path
+           (assoc-ref emacs:%standard-phases 'add-install-to-native-load-path))
+         (add-after 'emacs-add-install-to-native-load-path 'emacs-install
            (assoc-ref emacs:%standard-phases 'install))
          (add-after 'emacs-install 'emacs-build
            (assoc-ref emacs:%standard-phases 'build))
-- 
2.37.3