diff mbox series

[bug#68609,1/2] gnu: python-pandas-stubs: Update to 1.5.3.230321.

Message ID 87jzo4t85z.fsf@troyfigiel.com
State New
Headers show
Series gnu: python-pandera: Fix build. | expand

Commit Message

Troy Figiel Jan. 20, 2024, 1:10 p.m. UTC
* gnu/packages/python-science.scm (python-pandas-stubs): Update to
1.5.3.230321.
[arguments]<#:test-flags>: Ignore tests that require a version of
python-pyarrow with ORC integration.
[native-inputs]: Add python-odfpy.
---
 gnu/packages/python-science.scm | 20 ++++++++++++++++----
 1 file changed, 16 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 3c131fe730..4eb0195889 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -580,8 +580,8 @@  (define-public python-pandas-stubs
     (name "python-pandas-stubs")
     ;; The versioning follows that of Pandas and uses the date of the
     ;; python-pandas-stubs release. This is the latest version of
-    ;; python-pandas-stubs for python-pandas 1.4.4.
-    (version "1.4.4.220919")
+    ;; python-pandas-stubs for python-pandas 1.5.3.
+    (version "1.5.3.230321")
     (source
      (origin
        ;; No tests in the PyPI tarball.
@@ -591,10 +591,21 @@  (define-public python-pandas-stubs
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "14fhj1y71akwl41ws7cpazsbq5b8wf4rwaydqq2h39q7gylpcp99"))))
+        (base32 "1blwlq5053pxnmx721zdd6v8njiybz4azribx2ygq33jcpmknda6"))))
     (build-system pyproject-build-system)
     (arguments
-     '(#:phases (modify-phases %standard-phases
+     (list
+      #:test-flags #~(list "-k"
+                           (string-append
+                            ;; The python-pyarrow package in Guix is not built
+                            ;; with ORC integration, causing these tests to
+                            ;; fail.
+                            "not test_orc"
+                            " and not test_orc_path"
+                            " and not test_orc_buffer"
+                            " and not test_orc_columns"
+                            " and not test_orc_bytes"))
+      #:phases '(modify-phases %standard-phases
                   (add-before 'check 'prepare-x
                     (lambda _
                       (system "Xvfb &")
@@ -607,6 +618,7 @@  (define-public python-pandas-stubs
     ;; tests will be skipped for now.
     (native-inputs (list python-lxml
                          python-matplotlib
+                         python-odfpy
                          python-pandas
                          python-poetry-core
                          python-pyarrow