diff mbox series

[bug#68609,2/2] gnu: python-pandera: Fix build.

Message ID 87il3ot84y.fsf@troyfigiel.com
State New
Headers show
Series gnu: python-pandera: Fix build. | expand

Commit Message

Troy Figiel Jan. 20, 2024, 1:55 p.m. UTC
* gnu/packages/python-science.scm (python-pandera): Fix build.
[source]: Delete tests/modin directory.
[native-inputs]: Remove python-modin.
---
 gnu/packages/python-science.scm | 15 +++++++++------
 1 file changed, 9 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 4eb0195889..3422302a87 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -661,16 +661,20 @@  (define-public python-pandera
        (sha256
         (base32 "1mnqk583z90k1n0z3lfa4rd0ng40v7hqfk7phz5gjmxlzfjbxa1x"))
        (modules '((guix build utils)))
-       ;; These tests require PySpark. We need to remove the entire directory,
-       ;; since the conftest.py in this directory contains a PySpark import.
-       ;; (See: https://github.com/pytest-dev/pytest/issues/7452)
-       (snippet '(delete-file-recursively "tests/pyspark"))))
+       ;; These tests require PySpark and Modin. We need to remove the entire
+       ;; directory, since the conftest.py in these directories contain
+       ;; imports.  (See: https://github.com/pytest-dev/pytest/issues/7452)
+       (snippet '(begin
+                   (delete-file-recursively "tests/pyspark")
+                   (delete-file-recursively "tests/modin")))))
     (build-system pyproject-build-system)
     (arguments
      (list
       #:test-flags '(list "-k"
                           (string-append
-                           ;; Needs python-pandas >= 1.5
+                           ;; Mypy functionality is experimental and relying
+                           ;; on pandas-stubs can lead to false
+                           ;; positives. These tests currently fail.
                            "not test_python_std_list_dict_generics"
                            " and not test_python_std_list_dict_empty_and_none"
                            " and not test_pandas_modules_importable"))))
@@ -692,7 +696,6 @@  (define-public python-pandera
     (native-inputs (list python-dask ;dask extra
                          python-fastapi ;fastapi extra
                          python-geopandas ;geopandas extra
-                         python-modin ;modin extra
                          python-pyarrow ;needed to run fastapi tests
                          python-pytest
                          python-pytest-asyncio