diff mbox series

[bug#38546,v4] Update Julia 1.3.1: almost done

Message ID 87imjvwvjx.fsf@guixSD.i-did-not-set--mail-host-address--so-tickle-me
State Accepted
Headers show
Series [bug#38546,v4] Update Julia 1.3.1: almost done | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Nicolò Balzarotti Feb. 24, 2020, 8:59 p.m. UTC
zimoun <zimon.toutoune@gmail.com> writes:

> Hi,
>
Hi, 
> Friendly ping. :-)
>

Here's a friendly 1.3.1 + HTTP.jl + dependencies patch submission.
Hopefully this time it's fine.  Package precompilation should be working
now (except json, whose cache, for some reason, is not valid and gets
rebuilt).
As a reminder: determinism is still not addressed and will be fixed in
the 1.4.0 release (hopefully, upstream is still not that responsive).
However, there are dozens of julia packages that I want to package, so
if this first batch is finally fine, more will come.
Thanks, Nicolò

>
> On Tue, 11 Feb 2020 at 18:58, zimoun <zimon.toutoune@gmail.com> wrote:
>>
>> Hi,
>>
>> Please find attach the almost updated julia using 2 patches. The first
>> add a dependency and the second update and patch.
>>
>> I hope that I do not screw up the indentation; sometimes my Emacs does
>> weird stuff. Anyway.
>>
>> If it is fine with you, please ping Ludo or any committer. :-)
>>
>>
>> Cheers,
>> simon

Comments

Simon Tournier Feb. 25, 2020, 4:12 p.m. UTC | #1
Hi Nicolò,

On Mon, 24 Feb 2020 at 21:59, Nicolò Balzarotti <anothersms@gmail.com> wrote:

> Here's a friendly 1.3.1 + HTTP.jl + dependencies patch submission.
> Hopefully this time it's fine.  Package precompilation should be working
> now (except json, whose cache, for some reason, is not valid and gets
> rebuilt).

Cool! Thank you.
I would like to first push 1.3.1, i.e., the patches v4.

Then let open another bug report with the patches attached here.
Otherwise, it seems a non-ending process. ;-)


About processing, if you use Magit to generate your patches, do not
forget to increment the reroll-count (W c C-m v) otherwise "git
format-patch -v5". It eases to know which version of the patches we
are talking about. For example, here it is the fifth.


> As a reminder: determinism is still not addressed and will be fixed in
> the 1.4.0 release (hopefully, upstream is still not that responsive).
> However, there are dozens of julia packages that I want to package, so
> if this first batch is finally fine, more will come.

Yes, hope soon. :-)


Cheers,
simon
Nicolò Balzarotti Feb. 25, 2020, 6:08 p.m. UTC | #2
zimoun <zimon.toutoune@gmail.com> writes:

> Hi Nicolò,
>
> On Mon, 24 Feb 2020 at 21:59, Nicolò Balzarotti <anothersms@gmail.com> wrote:
>
>> Here's a friendly 1.3.1 + HTTP.jl + dependencies patch submission.
>> Hopefully this time it's fine.  Package precompilation should be working
>> now (except json, whose cache, for some reason, is not valid and gets
>> rebuilt).
>
> Cool! Thank you.
> I would like to first push 1.3.1, i.e., the patches v4.
>
OOk
> Then let open another bug report with the patches attached here.
> Otherwise, it seems a non-ending process. ;-)
>
>
> About processing, if you use Magit to generate your patches, do not
> forget to increment the reroll-count (W c C-m v) otherwise "git
> format-patch -v5". It eases to know which version of the patches we
> are talking about. For example, here it is the fifth.
>
Thanks! Didn't know about it. Should I re-submit them with the v5 prefix?
>
>> As a reminder: determinism is still not addressed and will be fixed in
>> the 1.4.0 release (hopefully, upstream is still not that responsive).
>> However, there are dozens of julia packages that I want to package, so
>> if this first batch is finally fine, more will come.
>
> Yes, hope soon. :-)
>
Nicolò
>
> Cheers,
> simon
diff mbox series

Patch

From 238554a69cab1f7b1eedb93d453e78587b0e4597 Mon Sep 17 00:00:00 2001
From: nixo <nicolo@nixo.xyz>
Date: Mon, 24 Feb 2020 16:37:10 +0100
Subject: [PATCH 16/16] gnu: Add julia-http.

* gnu/packages/julia-xyz.scm (julia-http): New variable.
---
 gnu/packages/julia-xyz.scm | 45 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 45 insertions(+)

diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 5130663e48..be3c776f49 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -165,6 +165,51 @@  factor.  Consequently, they have a fixed number of digits (bits) after the
 decimal (radix) point.")
     (license license:expat)))
 
+(define-public julia-http
+  (package
+    (name "julia-http")
+    (version "0.8.9")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/JuliaWeb/HTTP.jl")
+             (commit (string-append "v" version))))
+       (file-name "HTTP")
+       (sha256
+        (base32 "11g49gnnacvmihnr0p3inqmsdw6wllyfkq5sbka09mwnrf3vahs7"))))
+    (build-system julia-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'install 'disable-network-tests
+           (lambda _
+             (substitute* "test/runtests.jl"
+               (("\"client.jl") "# \"client.jl")
+               (("\"multipart.jl") "# \"multipart.jl")
+               (("\"aws4.jl") "# \"as4.jl")
+               ;; some of those might still be saved
+               (("\"async.jl") "# \"async.jl")
+               (("\"server.jl") "# \"server.jl"))
+             (substitute* "test/websockets.jl"
+               (("for s in socket_type") "for s in []"))
+             (substitute* "test/messages.jl"
+               (("@testset \"Read methods\" ") "return\n"))
+             #t)))))
+    (propagated-inputs
+     `(("julia-inifile" ,julia-inifile)
+       ("julia-mbedtls" ,julia-mbedtls)
+       ("julia-compat" ,julia-compat)))
+    ;; required for tests
+    (inputs
+     `(("julia-json" ,julia-json)
+       ("julia-bufferedstreams" ,julia-bufferedstreams)))
+    (home-page "https://juliaweb.github.io/HTTP.jl/")
+    (synopsis "HTTP support for Julia")
+    (description "@code{HTTP.jl} is a Julia library for HTTP Messages,
+implementing both a client and a server.")
+    (license license:expat)))
+
 (define-public julia-inifile
   (package
     (name "julia-inifile")
-- 
2.25.0