diff mbox series

[bug#41167] V2 Re: [bug#41167] [PATCH 5/5] gnu: Add julia-compat.

Message ID 87imh25g80.fsf@guixSD.i-did-not-set--mail-host-address--so-tickle-me
State Accepted
Headers show
Series [bug#41167] V2 Re: [bug#41167] [PATCH 5/5] gnu: Add julia-compat. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Nicolò Balzarotti May 11, 2020, 9:11 p.m. UTC
Ludovic Courtès <ludo@gnu.org> writes:

Thank you for the review Ludo!

Here's the new julia-compat patch, hope it's correct this time!

> Hello!
>
> nixo <anothersms@gmail.com> skribis:
>
>> * julia-xyz.scm: New file.
>> * local.mk: Add julia-xyz.scm to it.
>> * julia-xyz.scm (julia-compat): New variable.
>
> Please spell out file names; you can also remove the last line, not
> needed here since it’s a new file.
>
>> --- /dev/null
>> +++ b/gnu/packages/julia-xyz.scm
>> @@ -0,0 +1,27 @@
>> +(define-module (gnu packages julia-xyz)
>
> Could you add the license/copyright header and resend this one?
>
> I’ll see if I can apply the whole series and build it tomorrow.
>
Prepare for a long build time!  Running tests takes like 4 hours.

> Thank you!
>
Thank You!
Nicolò

> Ludo’.

Comments

Ludovic Courtès May 12, 2020, 1:36 p.m. UTC | #1
Hi Nicolò,

Nicolò Balzarotti <anothersms@gmail.com> skribis:

>> Hello!
>>
>> nixo <anothersms@gmail.com> skribis:
>>
>>> * julia-xyz.scm: New file.
>>> * local.mk: Add julia-xyz.scm to it.
>>> * julia-xyz.scm (julia-compat): New variable.
>>
>> Please spell out file names; you can also remove the last line, not
>> needed here since it’s a new file.
>>
>>> --- /dev/null
>>> +++ b/gnu/packages/julia-xyz.scm
>>> @@ -0,0 +1,27 @@
>>> +(define-module (gnu packages julia-xyz)
>>
>> Could you add the license/copyright header and resend this one?
>>
>> I’ll see if I can apply the whole series and build it tomorrow.
>>
> Prepare for a long build time!  Running tests takes like 4 hours.

Ouch, indeed.  It went fine though!

I pushed the whole series.  Note that I modified the patch-adjusting
patch to preserve the comment that was originally there.

Nitpick: for future patches, I recommend avoiding “Fix …” in the subject
line, unless (1) there’s a bug report and the commit log links to it, or
(2) the commit log explains what’s being fixed.  (It wasn’t clear to me
whether the first two patches were “fixing” something that didn’t work
at all, and to what extent.)

Anyway, thumbs up for the upgrade!  \o/

Thanks,
Ludo’.
diff mbox series

Patch

From fc5a6eae3608872776902cb51aa33548cc55c42e Mon Sep 17 00:00:00 2001
From: nixo <nicolo@nixo.xyz>
Date: Sat, 9 May 2020 18:33:03 +0200
Subject: [PATCH 5/5] gnu: Add julia-compat.

* gnu/packages/julia-xyz.scm: New file.
* gnu/local.mk: Add packages/julia-xyz.scm to it.
---
 gnu/local.mk               |  1 +
 gnu/packages/julia-xyz.scm | 45 ++++++++++++++++++++++++++++++++++++++
 2 files changed, 46 insertions(+)
 create mode 100644 gnu/packages/julia-xyz.scm

diff --git a/gnu/local.mk b/gnu/local.mk
index a7ccec5e0b..9df42e47fe 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -291,6 +291,7 @@  GNU_SYSTEM_MODULES =				\
   %D%/packages/jrnl.scm				\
   %D%/packages/jose.scm				\
   %D%/packages/julia.scm			\
+  %D%/packages/julia-xyz.scm			\
   %D%/packages/jupyter.scm			\
   %D%/packages/kawa.scm				\
   %D%/packages/kde.scm				\
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
new file mode 100644
index 0000000000..f1da66a4be
--- /dev/null
+++ b/gnu/packages/julia-xyz.scm
@@ -0,0 +1,45 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages julia-xyz)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages)
+  #:use-module (guix git-download)
+  #:use-module (guix build-system julia))
+
+(define-public julia-compat
+  (package
+    (name "julia-compat")
+    (version "3.9.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/JuliaLang/Compat.jl")
+             (commit (string-append "v" version))))
+       (file-name "Compat")
+       (sha256
+        (base32 "01vwjr2134bzgnaxwd67knbibbhnfgnqjw7gxrp29s6y2a6j3882"))))
+    (build-system julia-build-system)
+    (home-page "https://github.com/JuliaLang/Compat.jl")
+    (synopsis "Compatibility across Julia versions")
+    (description "The Compat package is designed to ease interoperability
+between older and newer versions of the Julia language.  The Compat package
+provides a macro that lets you use the latest syntax in a backwards-compatible
+way.")
+    (license license:expat)))
-- 
2.26.2