diff mbox series

[bug#56111] gnu: playerctl: update to 2.4.1.

Message ID 87h74ep06p.fsf@gmail.com
State Accepted
Headers show
Series [bug#56111] gnu: playerctl: update to 2.4.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Jose G Perez Taveras June 21, 2022, 2:02 p.m. UTC
Christopher Baines <mail@cbaines.net> writes:

> [[PGP Signed Part:Undecided]]
>
> Jose G Perez Taveras <josegpt27@gmail.com> writes:
>
>> Hello,
>>
>> Here is an update to playerctl to 2.4.1 and fixed dependencies.
>> It uses `dbus-launch' to start a new daemon.
>>
>> This is my first time sending a patch, I would be very happy if you
>> could point me out to anything I should know.
>
> Hi Jose,
>
> Thanks for the patch.
>
>> +    (propagated-inputs (list dbus))
>
> The addition of dbus as a propagated input was the only thing that stood
> out to me.
>
> If playerctl does call out to dbus-launch, then patching the source to
> refer to the specific /gnu/store/...-dbus/.../dbus-launch binary would
> be the nicest approach, since that would avoid propagating dbus.
>
> Is it necessary to propagate the dbus package, and if so, what doesn't
> work if you don't?
>
> Thanks,
>
> Chris
>
> [[End of PGP Signed Part]]

Hello Christopher,

I kept on testing the patch. As you mentioned, propagating dbus is not
necessary for the package to work correctly.

Thank you for the feedback.

Best,
josegpt

Here's an updated version of the patch.

---
 gnu/packages/music.scm | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)


base-commit: d13ffd1580ec2253b6e05fb6300c3629aee893e3

Comments

Jose G Perez Taveras June 28, 2022, 1:19 p.m. UTC | #1
Hello,

I would like to know if there are any updates in regards to this patch?
Christopher Baines June 28, 2022, 10:03 p.m. UTC | #2
Jose G Perez Taveras <josegpt27@gmail.com> writes:

> Hello,
>
> I would like to know if there are any updates in regards to this patch?

I've gone ahead and pushed the updated patch as
aa565e7a10a3d8690a4296f8edf12abaa3c215c5.

Thanks,

Chris
diff mbox series

Patch

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 60cb176320..2d0d582e6c 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -48,6 +48,7 @@ 
 ;;; Copyright © 2022 Remco van 't Veer <remco@remworks.net>
 ;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
+;;; Copyright © 2022 Jose G Perez Taveras <josegpt27@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -5562,7 +5563,7 @@  (define-public pragha
 (define-public playerctl
   (package
     (name "playerctl")
-    (version "2.2.1")
+    (version "2.4.1")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -5571,14 +5572,14 @@  (define-public playerctl
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "17hi33sw3663qz5v54bqqil31sgkrlxkb2l5bgqk87pac6x2wnbz"))))
+                "0ij065blj3h5v6iivvpmgh1095vicj1nc7hp1nhlhpqagd98l89s"))))
     (build-system meson-build-system)
     (arguments
-     `(#:configure-flags '("-Dintrospection=false" "-Dgtk-doc=false")))
-    (inputs (list python-pygobject))
+     `(#:configure-flags '("-Dgtk-doc=false")))
     (native-inputs
      `(("glib:bin" ,glib "bin")
-       ("pkg-config" ,pkg-config)))
+       ("pkg-config" ,pkg-config)
+       ("gobject-introspection" ,gobject-introspection)))
     (synopsis "Control MPRIS-supporting media player applications")
     (description
      "Playerctl is a command-line utility and library for controlling media