diff mbox series

[bug#45972] Add julia-json with dependencies

Message ID 87ft2xzu1g.fsf@guixSD.i-did-not-set--mail-host-address--so-tickle-me
State Accepted
Headers show
Series [bug#45972] Add julia-json with dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Nicolò Balzarotti Jan. 18, 2021, 11:47 p.m. UTC
Hi guix!

This patch series adds julia-json together with its dependencies.

It also enable tests for julia packages.

Thanks, Nicolò

Comments

Ludovic Courtès Jan. 26, 2021, 9:33 p.m. UTC | #1
Hi Nicolò,

Nicolò Balzarotti <anothersms@gmail.com> skribis:

> This patch series adds julia-json together with its dependencies.

Neat.  I looked at it quickly and it LGTM.  Nitpicks:

> +    (synopsis "Julia implementation of associative containers that preserve
> +insertion order")

Maybe remove “Julia implementation of”.

> +    (description "This package implements OrderedDicts and OrderedSets, which

Ideally use @code for identifiers.

> +    (synopsis "Fixed point types for julia")

s/julia/Julia/

> +    (synopsis "JSON parsing and printing")
> +    (description "Parsing and printing JSON in pure Julia.")

Please make that a full sentence.

If you’re confident with the licenses and ‘guix lint’ is happy,
please push!  Nice to see more Julia packages.

Ludo’.
diff mbox series

Patch

From 3ebd72ef6a55ad46522fe2534b775e9b6d20130f Mon Sep 17 00:00:00 2001
From: nixo <nicolo@nixo.xyz>
Date: Tue, 19 Jan 2021 00:06:34 +0100
Subject: [PATCH 9/9] gnu: Add julia-json.

* gnu/packages/julia-xyz.scm (julia-json): New variable.
---
 gnu/packages/julia-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 429ab0afad..7aba08cdb1 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -125,6 +125,30 @@  scaled by a constant factor.  Consequently, they have a fixed number of
 digits (bits) after the decimal (radix) point.")
     (license license:expat)))
 
+(define-public julia-json
+  (package
+    (name "julia-json")
+    (version "0.21.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/JuliaIO/JSON.jl")
+             (commit (string-append "v" version))))
+       (file-name "JSON")
+       (sha256
+        (base32 "1f9k613kbknmp4fgjxvjaw4d5sfbx8a5hmcszmp1w9rqfqngjx9m"))))
+    (build-system julia-build-system)
+    (propagated-inputs
+     `(("julia-datastructures" ,julia-datastructures)
+       ("julia-fixedpointnumbers" ,julia-fixedpointnumbers)
+       ("julia-parsers" ,julia-parsers)
+       ("julia-offsetarrays" ,julia-offsetarrays)))
+    (home-page "https://github.com/JuliaIO/JSON.jl")
+    (synopsis "JSON parsing and printing")
+    (description "Parsing and printing JSON in pure Julia.")
+    (license license:expat)))
+
 (define-public julia-orderedcollections
   (package
     (name "julia-orderedcollections")
-- 
2.29.2