diff mbox series

[bug#56204] Add guile-goblins

Message ID 87edzbjl2h.fsf@dustycloud.org
State Accepted
Headers show
Series [bug#56204] Add guile-goblins | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Christine Lemmer-Webber June 26, 2022, 7:09 p.m. UTC
Ludovic Courtès <ludo@gnu.org> writes:

> Maxime Devos <maximedevos@telenet.be> skribis:
>
>> Christine Lemmer-Webber schreef op vr 24-06-2022 om 17:24 [-0400]:
>>> +    (version "0.8")
>>> +    (source
>>> +     (origin
>>> +       (method git-fetch)
>>> +       (uri (git-reference
>>> +             (url "https://gitlab.com/spritely/guile-goblins/")
>>> +             (commit (string-append "v" version))))
>>> +       (file-name (string-append name "-" version))
>>> +       (sha256
>>> +        (base32
>>> +         "1mmyykh79jwhrfgnhhw94aw7a8m6qw249kj7k60ynj16mcfm5iyy"))))
>>
>>
>> I'm not seeing "--target" in  the invocation of "$(GUILE_TOOLS)
>> compile", so I don't think that currently it will cross-compile
>> correctly.  Could you add a --target=... in the Makefile.am?
>
> That can come upstream in the next version of Goblins IMO.
>
> Ludo’.

Cool, I added it to commit 6664daa27e9b3eb3220ba83d9c874b730e792f90 in
guile-goblins.  However I was just mimicing guile-gcrypt, so I'm not
sure if it's right:

#+BEGIN_SRC diff
#+END_SRC

Should that be sufficient?

Notably, the Makefile.am here was bootstrapped using guile-hall, so my
suspicion is that this is an update that should be made in guile-hall's
templates also, then everyone can benefit.

The next release of Goblins should be due out very quickly, I think, so
we'll be able to take advantage of it then.

Comments

M June 26, 2022, 8:50 p.m. UTC | #1
Christine Lemmer-Webber schreef op zo 26-06-2022 om 15:09 [-0400]:
> #+BEGIN_SRC diff
> diff --git a/Makefile.am b/Makefile.am
> index b8d4944..b056337 100644
> --- a/Makefile.am
> +++ b/Makefile.am
> @@ -32,7 +32,7 @@ EXTRA_DIST = $(SOURCES) $(NOCOMP_SOURCES)
>  GUILE_WARNINGS = -Wunbound-variable -Warity-mismatch -Wformat
>  SUFFIXES = .scm .go
>  .scm.go:
> -	$(AM_V_GEN)$(top_builddir)/pre-inst-env $(GUILE_TOOLS) compile $(GUILE_WARNINGS) -o "$@" "$<"
> +	$(AM_V_GEN)$(top_builddir)/pre-inst-env $(GUILE_TOOLS) compile $(GUILE_TARGET) $(GUILE_WARNINGS) -o "$@" "$<"
>  
>  SOURCES = goblins.scm \
>            goblins/ocapn/crypto-stubs.scm \
> #+END_SRC
> 
> Should that be sufficient?

I think so (untested)?

> Notably, the Makefile.am here was bootstrapped using guile-hall, so
> my suspicion is that this is an update that should be made in
> guile-hall's templates also, then everyone can benefit.

Agreed.

Greetings,
Maxime.
Ludovic Courtès June 27, 2022, 10:22 a.m. UTC | #2
Hi,

Christine Lemmer-Webber <cwebber@dustycloud.org> skribis:

> #+BEGIN_SRC diff
> diff --git a/Makefile.am b/Makefile.am
> index b8d4944..b056337 100644
> --- a/Makefile.am
> +++ b/Makefile.am
> @@ -32,7 +32,7 @@ EXTRA_DIST = $(SOURCES) $(NOCOMP_SOURCES)
>  GUILE_WARNINGS = -Wunbound-variable -Warity-mismatch -Wformat
>  SUFFIXES = .scm .go
>  .scm.go:
> -	$(AM_V_GEN)$(top_builddir)/pre-inst-env $(GUILE_TOOLS) compile $(GUILE_WARNINGS) -o "$@" "$<"
> +	$(AM_V_GEN)$(top_builddir)/pre-inst-env $(GUILE_TOOLS) compile $(GUILE_TARGET) $(GUILE_WARNINGS) -o "$@" "$<"
>  
>  SOURCES = goblins.scm \
>            goblins/ocapn/crypto-stubs.scm \
> #+END_SRC
>
> Should that be sufficient?

Yes, that LGTM, provided GUILE_TARGET is properly computed, like in
Guile-Gcrypt’s ‘configure.ac’.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/Makefile.am b/Makefile.am
index b8d4944..b056337 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -32,7 +32,7 @@  EXTRA_DIST = $(SOURCES) $(NOCOMP_SOURCES)
 GUILE_WARNINGS = -Wunbound-variable -Warity-mismatch -Wformat
 SUFFIXES = .scm .go
 .scm.go:
-	$(AM_V_GEN)$(top_builddir)/pre-inst-env $(GUILE_TOOLS) compile $(GUILE_WARNINGS) -o "$@" "$<"
+	$(AM_V_GEN)$(top_builddir)/pre-inst-env $(GUILE_TOOLS) compile $(GUILE_TARGET) $(GUILE_WARNINGS) -o "$@" "$<"
 
 SOURCES = goblins.scm \
           goblins/ocapn/crypto-stubs.scm \